summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/host
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2024-03-09 06:44:55 +0300
committerPatrick Williams <patrick@stwcx.xyz>2024-03-11 18:18:37 +0300
commitb81c1fb76edaf43e864854cb668fd5e7b1f88816 (patch)
tree4b0790b60e411c86c4e21fc23de34c6b22030488 /meta-phosphor/recipes-phosphor/host
parent828c130f59bb3e2cb5cdfd47ac424aa4407bb0b3 (diff)
downloadopenbmc-b81c1fb76edaf43e864854cb668fd5e7b1f88816.tar.xz
meta-phosphor: add vardeps for HOST and CHASSIS instances
If a system were to change the OBMC_HOST_INSTANCES or OBMC_CHASSIS_INSTANCES, many packages (incorrectly) do not get rebuilt. This is because the variables are evaluated within Python contexts and are not manually specified in the `vardeps`. Add as necessary. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I84651a1a85a5c977be674d8b26b6e43e5ab46850
Diffstat (limited to 'meta-phosphor/recipes-phosphor/host')
-rw-r--r--meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
index 6c8f8ee71b..2a67b77e08 100644
--- a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
@@ -13,6 +13,7 @@ START_TGTFMT = "obmc-host-startmin@{1}.target"
START_INSTFMT = "op-start-host@{0}.service"
START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK[vardeps] += "OBMC_HOST_INSTANCES OBMC_CHASSIS_INSTANCES"
inherit skeleton-gdbus
inherit obmc-phosphor-dbus-service