summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/interfaces
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2024-02-23 18:46:37 +0300
committerPatrick Williams <patrick@stwcx.xyz>2024-02-28 01:14:10 +0300
commitde59cd5f68c2fa00722b20e724b5bd39a39c50c1 (patch)
tree353d615a9a83c646c291d518290f0e3eba33b642 /meta-phosphor/recipes-phosphor/interfaces
parent4b5fdfa2f1c4a65e86593ac8a36252344bec2819 (diff)
downloadopenbmc-de59cd5f68c2fa00722b20e724b5bd39a39c50c1.tar.xz
bmcweb: allow mutual-tls-common-name-parsing setting
Add a recipe variable that controls the mutual-tls-common-name-parsing setting, when mutual-tls-auth is enabled: MUTUAL_TLS_PARSING. Default to 'username' to match the underlying repository. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I5eea87f51981402d82da23b7853ab74e7bf4f03b
Diffstat (limited to 'meta-phosphor/recipes-phosphor/interfaces')
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index a61a14af79..76c0834412 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -32,9 +32,14 @@ PACKAGECONFIG ??= "mutual-tls-auth"
PACKAGECONFIG[insecure-redfish-expand]="-Dinsecure-enable-redfish-query=enabled"
PACKAGECONFIG[mutual-tls-auth]="-Dmutual-tls-auth=enabled,-Dmutual-tls-auth=disabled"
+MUTUAL_TLS_PARSING="username"
+
EXTRA_OEMESON = " \
--buildtype=minsize \
-Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'mutual-tls-auth', \
+ '-Dmutual-tls-common-name-parsing=' + d.getVar('MUTUAL_TLS_PARSING', True), \
+ '', d)} \
"
do_install_ptest() {