summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/inventory
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-03-05 18:27:35 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-13 03:15:12 +0300
commitb49af0c8440fed84882c60c3d7b0a128c74bb8d9 (patch)
treec91010c1407384379147de43e7f072ef4dd2dca2 /meta-phosphor/recipes-phosphor/inventory
parentf66fb81674bb5796b5d2cd06754f02ef6f1088a2 (diff)
downloadopenbmc-b49af0c8440fed84882c60c3d7b0a128c74bb8d9.tar.xz
phosphor-inventory-manager: fix missing python dep
The repo runs python to generate code or validate config, which requires python and the dependent python packages. Previously that happens to be satisfied by sdbusplus's RDEPENDS. If sdbusplus is changed to use python3, this repo fails to built because it lacks of dependency. See details in https://lists.ozlabs.org/pipermail/openbmc/2020-February/020771.html This commit fixes the depends by adding the required python and python-packages so that it builds fine. (From meta-phosphor rev: 89d17815d5fd3a5247479feb01682c741698a8b5) Change-Id: I09852819750d4faa320a9b9f236bb9ee2de94fc5 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/inventory')
-rw-r--r--meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
index 520cdcc992..9b5530b611 100644
--- a/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
@@ -23,6 +23,9 @@ DEPENDS += " \
sdbusplus-native \
autoconf-archive-native \
libcereal \
+ ${PYTHON_PN}-native \
+ ${PYTHON_PN}-pyyaml-native \
+ ${PYTHON_PN}-mako-native \
"
OBMC_INVENTORY_PATH="${OBMC_DBUS_PATH_ROOT}/inventory"