summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb29
1 files changed, 14 insertions, 15 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
index 24c4941dc6..303a0ef07c 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
@@ -1,9 +1,7 @@
SUMMARY = "Phosphor IPMI daemon configuration"
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit allarch
+PR = "r1"
SRC_URI = " \
file://cipher_list.json \
@@ -17,23 +15,12 @@ SRC_URI = " \
file://cs_privilege_levels.json \
"
-FILES:${PN} = " \
- ${datadir}/ipmi-providers/cipher_list.json \
- ${datadir}/ipmi-providers/dcmi_cap.json \
- ${datadir}/ipmi-providers/dcmi_sensors.json \
- ${datadir}/ipmi-providers/dev_id.json \
- ${datadir}/ipmi-providers/power_reading.json \
- ${datadir}/ipmi-providers/channel_access.json \
- ${datadir}/ipmi-providers/channel_config.json \
- ${datadir}/ipmi-providers/entity-map.json \
- ${datadir}/ipmi-providers/cs_privilege_levels.json \
- "
+inherit allarch
do_fetch[noexec] = "1"
do_patch[noexec] = "1"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
-
do_install() {
install -d ${D}${datadir}/ipmi-providers
install -m 0644 -D ${WORKDIR}/cipher_list.json \
@@ -55,3 +42,15 @@ do_install() {
install -m 0644 -D ${WORKDIR}/cs_privilege_levels.json \
${D}${datadir}/ipmi-providers/cs_privilege_levels.json
}
+
+FILES:${PN} = " \
+ ${datadir}/ipmi-providers/cipher_list.json \
+ ${datadir}/ipmi-providers/dcmi_cap.json \
+ ${datadir}/ipmi-providers/dcmi_sensors.json \
+ ${datadir}/ipmi-providers/dev_id.json \
+ ${datadir}/ipmi-providers/power_reading.json \
+ ${datadir}/ipmi-providers/channel_access.json \
+ ${datadir}/ipmi-providers/channel_config.json \
+ ${datadir}/ipmi-providers/entity-map.json \
+ ${datadir}/ipmi-providers/cs_privilege_levels.json \
+ "