summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/libpldm
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2023-06-27 14:59:51 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-07-04 18:35:12 +0300
commit83228dc3df3ccce7b9effbdcee43c149f79e07e2 (patch)
tree1fbd35e69e3477d04d38311f31519d264c82dc28 /meta-phosphor/recipes-phosphor/libpldm
parent993667f7fe0feabd878546dff460e1cf2dec1801 (diff)
downloadopenbmc-83228dc3df3ccce7b9effbdcee43c149f79e07e2.tar.xz
meta-phosphor: libpldm: Rework ABI PACKAGECONFIG configuration
Define three categories of ABI configuration via PACKAGECONFIG: 1. abi-production: Only deprecated and stable symbols are exposed 2. abi-maintenance: Only stable and testing symbols are exposed 3. abi-development: All deprecated, stable and testing symbols are exposed This makes it relatively straight-forward to perform broad testing for use of deprecated functions by setting `PACKAGECONFIG = "abi-maintenance"` in a `libpldm_%.bbappend` in the relevant meta layer. However, build for abi-production by default. Change-Id: I9df824e2543829dbe66a7203240e5367ffded3e3 Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/libpldm')
-rw-r--r--meta-phosphor/recipes-phosphor/libpldm/libpldm_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-phosphor/libpldm/libpldm_git.bb b/meta-phosphor/recipes-phosphor/libpldm/libpldm_git.bb
index acb8399394..4d0766266e 100644
--- a/meta-phosphor/recipes-phosphor/libpldm/libpldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/libpldm/libpldm_git.bb
@@ -4,9 +4,13 @@ HOMEPAGE = "https://github.com/openbmc/libpldm"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRCREV = "4e1ba8a736a4272e15f8e4541858407821d6b59e"
-LIBPLDM_ABI_STABLE = "deprecated,stable"
-LIBPLDM_ABI_TESTING = "deprecated,stable,testing"
-PACKAGECONFIG[abi-testing] = "-Dabi=${LIBPLDM_ABI_TESTING},-Dabi=${LIBPLDM_ABI_STABLE},,"
+LIBPLDM_ABI_DEVELOPMENT = "deprecated,stable,testing"
+LIBPLDM_ABI_MAINTENANCE = "stable,testing"
+LIBPLDM_ABI_PRODUCTION = "deprecated,stable"
+PACKAGECONFIG ??= "abi-production"
+PACKAGECONFIG[abi-development] = "-Dabi=${LIBPLDM_ABI_DEVELOPMENT},,,"
+PACKAGECONFIG[abi-maintenance] = "-Dabi=${LIBPLDM_ABI_MAINTENANCE},,,"
+PACKAGECONFIG[abi-production] = "-Dabi=${LIBPLDM_ABI_PRODUCTION},,,"
PACKAGECONFIG[oem-ibm] = "-Doem-ibm=enabled,-Doem-ibm=disabled,,"
PV = "git${SRCPV}"