summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/logging
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-03-23 06:41:42 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-03-28 21:44:54 +0300
commit44f3cceaa77d532e9475eafb2a6d4e83bc00fc4b (patch)
tree1dcd7e9fb1a0624a63b30cd14b84124baf670926 /meta-phosphor/recipes-phosphor/logging
parentd108709597c5981f1f13c4729ff6644f73a93197 (diff)
downloadopenbmc-44f3cceaa77d532e9475eafb2a6d4e83bc00fc4b.tar.xz
meta-phosphor: Fix explicit dependencies antipattern
Out of the box bitbake examines built applications, automatically adds runtime dependencies and thus ensures any library packages dependencies are automatically added to images, sdks, etc. There is no need to list them explicitly in a recipe. Dependencies change over time, and listing them explicitly is likely prone to errors - the net effect being unnecessary shared library packages being installed into images. Consult https://www.yoctoproject.org/docs/latest/mega-manual/mega-manual.html#var-RDEPENDS for information on when to use explicit runtime dependencies. (From meta-phosphor rev: 26873c99d30b55e21a920c9851f21c3e2eab19f7) Change-Id: I38640d75a2d834c07d45ddcdb0162f1a23f848d9 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/logging')
-rw-r--r--meta-phosphor/recipes-phosphor/logging/ffdc_git.bb3
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb2
2 files changed, 2 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-phosphor/logging/ffdc_git.bb b/meta-phosphor/recipes-phosphor/logging/ffdc_git.bb
index c97afb73b3..81b7f4536e 100644
--- a/meta-phosphor/recipes-phosphor/logging/ffdc_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/ffdc_git.bb
@@ -6,8 +6,9 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+DEPENDS += "systemd"
+
RDEPENDS_${PN} += " \
- systemd \
${VIRTUAL-RUNTIME_base-utils} \
"
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
index 636a4a617c..2c6f75c313 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -41,14 +41,12 @@ PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
DBUS_PACKAGES = "${LOGGING_PACKAGES}"
-RDEPENDS_${PN}-base += "sdbusplus phosphor-dbus-interfaces"
FILES_${PN}-base += " \
${sbindir}/phosphor-log-manager \
${libdir}/libphosphor_logging.so.* \
"
DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
-RDEPENDS_phosphor-rsyslog-config += "sdbusplus phosphor-dbus-interfaces"
DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
FILES_phosphor-rsyslog-config += " \
${sbindir}/phosphor-rsyslog-conf \