summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/mrw/mrw-native_git.bb
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-phosphor/mrw/mrw-native_git.bb
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-phosphor/mrw/mrw-native_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/mrw/mrw-native_git.bb19
1 files changed, 9 insertions, 10 deletions
diff --git a/meta-phosphor/recipes-phosphor/mrw/mrw-native_git.bb b/meta-phosphor/recipes-phosphor/mrw/mrw-native_git.bb
index d9776021e3..4f98c4dc95 100644
--- a/meta-phosphor/recipes-phosphor/mrw/mrw-native_git.bb
+++ b/meta-phosphor/recipes-phosphor/mrw/mrw-native_git.bb
@@ -1,7 +1,12 @@
SUMMARY = "Phosphor OpenBMC machine readable workbook"
DESCRIPTION = "Pulls down system specific data"
-PR = "r1"
+LICENSE = "${PHOSPHOR_MRW_LICENSE}"
+LIC_FILES_CHKSUM = "${PHOSPHOR_MRW_LIC_FILES_CHKSUM}"
+SRCREV = "${PHOSPHOR_MRW_REV}"
PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "${PHOSPHOR_MRW_URI}"
S = "${WORKDIR}/git"
@@ -9,17 +14,11 @@ inherit obmc-xmlpatch
inherit mrw-xml
inherit native
-PHOSPHOR_MRW_LICENSE ?= "Apache-2.0"
-PHOSPHOR_MRW_LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-PHOSPHOR_MRW_URI ?= "http://missing-mrw-uri"
-
-LICENSE = "${PHOSPHOR_MRW_LICENSE}"
-LIC_FILES_CHKSUM = "${PHOSPHOR_MRW_LIC_FILES_CHKSUM}"
-SRC_URI += "${PHOSPHOR_MRW_URI}"
-SRCREV = "${PHOSPHOR_MRW_REV}"
-
do_install() {
install -d ${D}/${mrw_datadir}
install -m 0644 ${MRW_XML} ${D}/${mrw_datadir}
}
+PHOSPHOR_MRW_LICENSE ?= "Apache-2.0"
+PHOSPHOR_MRW_LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+PHOSPHOR_MRW_URI ?= "http://missing-mrw-uri"