summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/packagegroups
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2022-02-24 07:34:08 +0300
committerAndrew Jeffery <andrew@aj.id.au>2022-02-26 04:08:30 +0300
commit55acd1c220418dde83eb3334e6eeee66f49c3486 (patch)
tree85328d907ff590494ac62960cb73251b30565831 /meta-phosphor/recipes-phosphor/packagegroups
parent37d3b1210e19365fad7102a405bed087f57cdde3 (diff)
downloadopenbmc-55acd1c220418dde83eb3334e6eeee66f49c3486.tar.xz
meta-phosphor: Add valgrind to obmc-phosphor-debugtools
Valgrind is useful for debugging memory corruption among other common runtime misbehaviours. Tested: `bitbake packagegroup-obmc-phosphor-debugtools -ne` and checked the RDEPENDS structure for Witherspoon (ast2500 = no valgrind) and Bletchley (ast2600 = with valgrind). Change-Id: I1e9729b2feb5b535a0a240e68a0ee4f6b31b7490 Signed-off-by: Andrew Jeffery <andrew@aj.id.au> Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/packagegroups')
-rw-r--r--meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb
index edcc9ff2c4..3118882270 100644
--- a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb
@@ -12,4 +12,10 @@ RDEPENDS:${PN} = " \
lmsensors-sensors \
tcpdump \
screen \
+ valgrind \
"
+
+# Some older arm architectures don't support valgrind, so explicitly remove
+# it as a dependency from them, but keep it by default in anything newer.
+RDEPENDS:${PN}:remove:armv5 = "valgrind"
+RDEPENDS:${PN}:remove:armv6 = "valgrind"