summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/packagegroups
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-phosphor/packagegroups
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-phosphor/packagegroups')
-rw-r--r--meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb11
-rw-r--r--meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb1
-rw-r--r--meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb15
3 files changed, 12 insertions, 15 deletions
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
index f7f4fda168..3abd95536c 100644
--- a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
@@ -1,14 +1,13 @@
+# Warning. Add additional providers with whitelists to distro or machine
+# configuration and not in recipe context (bbappend) otherwise ipmid will not
+# know about your whitelist.
SUMMARY = "OpenBMC - IPMI providers"
+SUMMARY:${PN}-libs = "Extra providers for ipmid."
+PROVIDES = "${PACKAGES}"
PR = "r1"
inherit packagegroup
-PROVIDES = "${PACKAGES}"
PACKAGES = "${PN}-libs"
-SUMMARY:${PN}-libs = "Extra providers for ipmid."
RDEPENDS:${PN}-libs = "${VIRTUAL-RUNTIME_phosphor-ipmi-providers}"
-
-# Warning. Add additional providers with whitelists to distro or machine
-# configuration and not in recipe context (bbappend) otherwise ipmid will not
-# know about your whitelist.
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb
index 546404fa57..872c4f1d58 100644
--- a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb
@@ -15,7 +15,6 @@ RDEPENDS:${PN} = " \
valgrind \
iperf3 \
"
-
# Some older arm architectures don't support valgrind, so explicitly remove
# it as a dependency from them, but keep it by default in anything newer.
RDEPENDS:${PN}:remove:armv5 = "valgrind"
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb
index 919c6b1abf..69283de7ab 100644
--- a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-yaml-providers.bb
@@ -1,19 +1,18 @@
-SUMMARY = "Phosphor OpenBMC - YAML Providers"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
# This is a packagegroup in name and principle but we do not want to inherit
# from packagegroup.bbclass. The point of this packagegroup is to get the
# sysroot populated with YAML files from the DEPENDS packages and if we inherit
# the packagegroup bbclass this doesn't happen, because that bbclass `deltask`
# a number that are required.
# inherit packagegroup
+SUMMARY = "Phosphor OpenBMC - YAML Providers"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+DEPENDS = "${OBMC_YAML_PROVIDER_RECIPES}"
+PR = "r1"
+
+RDEPENDS:${PN} = "${OBMC_YAML_PROVIDER_RECIPES}"
OBMC_YAML_PROVIDER_RECIPES += " \
phosphor-led-manager-yaml-provider \
phosphor-software-manager-yaml-provider \
"
-
-DEPENDS = "${OBMC_YAML_PROVIDER_RECIPES}"
-RDEPENDS:${PN} = "${OBMC_YAML_PROVIDER_RECIPES}"