summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/trace-enable
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-phosphor/trace-enable
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-phosphor/trace-enable')
-rw-r--r--meta-phosphor/recipes-phosphor/trace-enable/trace-enable.bb24
1 files changed, 11 insertions, 13 deletions
diff --git a/meta-phosphor/recipes-phosphor/trace-enable/trace-enable.bb b/meta-phosphor/recipes-phosphor/trace-enable/trace-enable.bb
index 37d5a035cf..e9456cb9f7 100644
--- a/meta-phosphor/recipes-phosphor/trace-enable/trace-enable.bb
+++ b/meta-phosphor/recipes-phosphor/trace-enable/trace-enable.bb
@@ -3,19 +3,12 @@ DESCRIPTION = "Enable Linux trace events based on a configuration file"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-RDEPENDS:${PN} = " \
- ${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'} \
- bash \
-"
-
-S = "${WORKDIR}"
-
SRC_URI += " file://trace-enable"
-TRACE_EVENTS = ""
+S = "${WORKDIR}"
+SYSTEMD_SERVICE:${PN} = "trace-enable.service"
-FILES:${PN} += "${sysconfdir}/trace-events.conf"
-FILES:${PN} += "${libexecdir}/trace-enable"
+inherit obmc-phosphor-systemd
do_install:append() {
install -d ${D}${sysconfdir}
@@ -25,11 +18,16 @@ do_install:append() {
done
echo >> ${D}${sysconfdir}/trace-events.conf
chmod 0644 ${D}${sysconfdir}/trace-events.conf
-
install -d ${D}${libexecdir}
install -m 0755 ${WORKDIR}/trace-enable ${D}${libexecdir}
}
-SYSTEMD_SERVICE:${PN} = "trace-enable.service"
+RDEPENDS:${PN} = " \
+ ${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'} \
+ bash \
+"
-inherit obmc-phosphor-systemd
+FILES:${PN} += "${sysconfdir}/trace-events.conf"
+FILES:${PN} += "${libexecdir}/trace-enable"
+
+TRACE_EVENTS = ""