summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-04-14 19:24:47 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-04-17 17:51:12 +0300
commitbccaff3439442ca820760c90da4a2308d3d61b0e (patch)
tree8c190c31e50a28f79d588cc49e101ddafb7b4a28 /meta-phosphor/recipes-phosphor
parent65682ac6176742b7d81b64c71d7a37913a39470b (diff)
downloadopenbmc-bccaff3439442ca820760c90da4a2308d3d61b0e.tar.xz
treewide: reduce append operators on SRC_URI
In a base bb file where we are setting the primary git repository, it is rare that we need to `SRC_URI +=`. This is an unnecessary pattern that seems to have been copied throughout the repository. Remove the pattern where appropriate and simply set SRC_URI directly. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I430186a82f9582ba6196f5bf66b659af4092b48d
Diffstat (limited to 'meta-phosphor/recipes-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb4
-rw-r--r--meta-phosphor/recipes-phosphor/console/obmc-console_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/dbus-top/dbus-top_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-objmgr_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/slpd-lite_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-bt_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/leds/phosphor-led-sysfs_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/network/phosphor-snmp_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/power/phosphor-psu-software-manager_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb2
20 files changed, 21 insertions, 21 deletions
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
index 7e34702c45..670fbfaa27 100644
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
@@ -15,7 +15,7 @@ PACKAGECONFIG[handler] = ",,,${VIRTUAL-RUNTIME_obmc-host-state-manager} ${VIRTUA
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-buttons.git;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-buttons.git;branch=master;protocol=https"
S = "${WORKDIR}/git"
SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
@@ -39,4 +39,4 @@ do_install:append() {
install -m 0644 -D ${WORKDIR}/gpio_defs.json \
${D}/etc/default/obmc/gpio
fi
-} \ No newline at end of file
+}
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
index 6d4bdc445f..4f20209119 100644
--- a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
@@ -15,7 +15,7 @@ PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir},
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/obmc-console;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/obmc-console;branch=master;protocol=https"
SRC_URI += "file://${BPN}.conf"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb b/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb
index 209d17628c..18648e603a 100644
--- a/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/datetime/phosphor-time-manager_git.bb
@@ -12,7 +12,7 @@ SRCREV = "4c5143f08a9da57a5abe814ef8e561a89cafc0e7"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-time-manager;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-time-manager;branch=master;protocol=https"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/dbus-top/dbus-top_git.bb b/meta-phosphor/recipes-phosphor/dbus-top/dbus-top_git.bb
index 260047a4ce..8114e5c38c 100644
--- a/meta-phosphor/recipes-phosphor/dbus-top/dbus-top_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus-top/dbus-top_git.bb
@@ -5,7 +5,7 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-SRC_URI += "git://github.com/openbmc/dbus-top;protocol=https;branch=main"
+SRC_URI = "git://github.com/openbmc/dbus-top;protocol=https;branch=main"
SRCREV = "abc3218cc2a9fe2de9fc9db214749b89f30c1774"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-objmgr_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-objmgr_git.bb
index d96b532c7f..e530fa9ad4 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-objmgr_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-objmgr_git.bb
@@ -13,7 +13,7 @@ SRCREV = "403027426d684b62459a2fe7225a7c60accb0e5c"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-objmgr;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-objmgr;branch=master;protocol=https"
PACKAGECONFIG ??= ""
PACKAGECONFIG[unit-failure-monitor] = "-Dunit-failure-monitor=enabled,-Dunit-failure-monitor=disabled,,"
diff --git a/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor_git.bb b/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor_git.bb
index 29b5737b4c..3a0f42a8d6 100644
--- a/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor_git.bb
+++ b/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor_git.bb
@@ -16,7 +16,7 @@ SRCREV = "0c60faaa0b53dad6561b95e66c0a601e442aeecf"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-gpio-monitor;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-gpio-monitor;branch=master;protocol=https"
SYSTEMD_PACKAGES = "${GPIO_PACKAGES}"
SYSTEMD_SERVICE:${PN}-monitor += "phosphor-multi-gpio-monitor.service"
diff --git a/meta-phosphor/recipes-phosphor/interfaces/slpd-lite_git.bb b/meta-phosphor/recipes-phosphor/interfaces/slpd-lite_git.bb
index 9d382a827b..0bf2fa3fea 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/slpd-lite_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/slpd-lite_git.bb
@@ -9,7 +9,7 @@ SRCREV = "55aac8e1bd6fafbbd9dcc8205dabec9c32ca2da4"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/slpd-lite;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/slpd-lite;branch=master;protocol=https"
SYSTEMD_SERVICE:${PN} += "slpd-lite.service"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-bt_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-bt_git.bb
index 19ecb539d6..b362eb6aa5 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-bt_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-bt_git.bb
@@ -9,7 +9,7 @@ SRCREV = "87a0efd5f529c39c0e2039519b6595aa0a22bbde"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/btbridge;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/btbridge;branch=master;protocol=https"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
index bc4f677959..890e7354e0 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
@@ -22,7 +22,7 @@ SRCREV = "e81b7c9d1aa571694200cc2afdca238cb23a7442"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-net-ipmid;branch=master;protocol=https"
S = "${WORKDIR}/git"
# install parameterized service and socket files
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-sysfs_git.bb b/meta-phosphor/recipes-phosphor/leds/phosphor-led-sysfs_git.bb
index 175955e215..735656c9d2 100644
--- a/meta-phosphor/recipes-phosphor/leds/phosphor-led-sysfs_git.bb
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-sysfs_git.bb
@@ -11,7 +11,7 @@ SRCREV = "3778f8efaa6ea351bb4d23042cbfa06b22c86a6f"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-led-sysfs;branch=master;protocol=https"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
index 0955fcf1d1..44761cd6fd 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -27,7 +27,7 @@ PACKAGECONFIG[openpower-pels] = " \
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-logging;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-logging;branch=master;protocol=https"
SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb b/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb
index ce1a6f9e5f..3fcd9b6a6f 100644
--- a/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb
+++ b/meta-phosphor/recipes-phosphor/mboxd/mboxd_git.bb
@@ -13,7 +13,7 @@ PACKAGECONFIG[virtual-pnor] = "--enable-virtual-pnor,--disable-virtual-pnor"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/hiomapd.git;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/hiomapd.git;branch=master;protocol=https"
SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
index 37b7e68b76..4cbbb7b22b 100644
--- a/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-network_git.bb
@@ -21,7 +21,7 @@ PACKAGECONFIG[persist-mac] = "-Dpersist-mac=true, -persist-mac=false,,"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-networkd;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-networkd;branch=master;protocol=https"
S = "${WORKDIR}/git"
SYSTEMD_PACKAGES = "${PN}"
diff --git a/meta-phosphor/recipes-phosphor/network/phosphor-snmp_git.bb b/meta-phosphor/recipes-phosphor/network/phosphor-snmp_git.bb
index 1fff205376..5bab66408e 100644
--- a/meta-phosphor/recipes-phosphor/network/phosphor-snmp_git.bb
+++ b/meta-phosphor/recipes-phosphor/network/phosphor-snmp_git.bb
@@ -12,7 +12,7 @@ SRCREV = "cab8c5368eda1547b882bfc519704cb06a4cb8af"
PV = "0.1+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-snmp;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-snmp;branch=master;protocol=https"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-psu-software-manager_git.bb b/meta-phosphor/recipes-phosphor/power/phosphor-psu-software-manager_git.bb
index e228c317e1..fcc8f6c1d6 100644
--- a/meta-phosphor/recipes-phosphor/power/phosphor-psu-software-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-psu-software-manager_git.bb
@@ -14,7 +14,7 @@ SRCREV = "200adf8fa81459195372f47135f2daf7f9fbbcdf"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-psu-code-mgmt;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-psu-code-mgmt;branch=master;protocol=https"
S = "${WORKDIR}/git"
SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.Software.Psu.Updater.service"
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
index 0063b4dab4..3539c991c6 100644
--- a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon_git.bb
@@ -18,7 +18,7 @@ PACKAGECONFIG[max31785-msl] = "-Denable-max31785-msl=true, -Denable-max31785-msl
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-hwmon;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-hwmon;branch=master;protocol=https"
SYSTEMD_PACKAGES = "${PN} max31785-msl"
SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.Hwmon@.service"
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
index 8ee77f798e..e5393bade0 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-state-manager_git.bb
@@ -235,7 +235,7 @@ RESET_INSTFMT_CTRL = "obmc-chassis-powerreset@{0}.target"
RESET_FMT_CTRL = "../${RESET_TMPL_CTRL}:${SYSD_TGT}.wants/${RESET_INSTFMT_CTRL}"
SYSTEMD_LINK:${PN}-obmc-targets += "${@compose_list_zip(d, 'RESET_FMT_CTRL', 'OBMC_CHASSIS_INSTANCES')}"
-SRC_URI += "git://github.com/openbmc/phosphor-state-manager;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-state-manager;branch=master;protocol=https"
SRCREV = "c079c3f0a348b1f1e32b05b07fdb6414c8d3b53f"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb b/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb
index 36d698d3a9..1b05c3a022 100644
--- a/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/users/phosphor-user-manager_git.bb
@@ -13,7 +13,7 @@ SRCREV = "e8d664d1689cfec3449ec964262d665f7b4ec873"
PV = "1.0+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/openbmc/phosphor-user-manager;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-user-manager;branch=master;protocol=https"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb b/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
index f2c39df4b0..8c0b922305 100644
--- a/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
+++ b/meta-phosphor/recipes-phosphor/video/uart-render-controller_git.bb
@@ -7,7 +7,7 @@ SRCREV = "08e854a6c425011d029e4e02241afee5060f15eb"
PV = "0.1+git${SRCPV}"
PR = "r1"
-SRC_URI += "git://github.com/jk-ozlabs/uart-render-controller;branch=master;protocol=https"
+SRC_URI = "git://github.com/jk-ozlabs/uart-render-controller;branch=master;protocol=https"
SRC_URI += "file://uart-render-controller.service"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb b/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
index 6c25329441..6970f57c4a 100644
--- a/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
+++ b/meta-phosphor/recipes-phosphor/watchdog/phosphor-watchdog_git.bb
@@ -16,7 +16,7 @@ DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "phosphor-logging"
DEPENDS += "systemd"
-SRC_URI += "git://github.com/openbmc/phosphor-watchdog;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/phosphor-watchdog;branch=master;protocol=https"
SRCREV = "d1b1e79b74238694c7a25f873ace2ff6dab1b683"
S = "${WORKDIR}/git"