summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-07-30 03:57:30 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-07-30 16:06:34 +0300
commitc9851953786aa3da7459434ed632cfcc64acb850 (patch)
tree228f7ccc0d5cf7be9189ef1ea08e9527e688921e /meta-phosphor/recipes-phosphor
parent9b3b14af18a7fba091e944975bbe7a0ebb2523bf (diff)
downloadopenbmc-c9851953786aa3da7459434ed632cfcc64acb850.tar.xz
phosphor-sel-logger: Add packageconfig options
This will allow us to migrate to meson without affecting machine specific overrides. Change-Id: Id0853dd9c0bcf0febd4286a8fbb0729499fa977e Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
index 9be7028862..de720730a2 100644
--- a/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
+++ b/meta-phosphor/recipes-phosphor/sel-logger/phosphor-sel-logger_git.bb
@@ -15,7 +15,12 @@ S = "${WORKDIR}/git"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-DEPENDS += "systemd sdbusplus boost phosphor-ipmi-host"
+DEPENDS += " \
+ boost \
+ sdbusplus \
+ systemd \
+ phosphor-logging \
+ "
SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=git"
SRCREV = "e9da2599f10f1b696f61c97f8c8036acfde05e18"
@@ -23,3 +28,10 @@ SRCREV = "e9da2599f10f1b696f61c97f8c8036acfde05e18"
PV = "0.1+git${SRCPV}"
SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Logging.IPMI.service"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[log-threshold] = "-DSEL_LOGGER_MONITOR_THRESHOLD_EVENTS=ON,-DSEL_LOGGER_MONITOR_THRESHOLD_EVENTS=OFF,"
+PACKAGECONFIG[log-pulse] = "-DREDFISH_LOG_MONITOR_PULSE_EVENTS=ON,-DREDFISH_LOG_MONITOR_PULSE_EVENTS=OFF,"
+PACKAGECONFIG[log-watchdog] = "-DSEL_LOGGER_MONITOR_WATCHDOG_EVENTS=ON,-DSEL_LOGGER_MONITOR_WATCHDOG_EVENTS=OFF,"
+PACKAGECONFIG[log-alarm] = "-DSEL_LOGGER_MONITOR_THRESHOLD_ALARM_EVENTS=ON,-DSEL_LOGGER_MONITOR_THRESHOLD_ALARM_EVENTS=OFF,"
+PACKAGECONFIG[send-to-logger] = "-DSEL_LOGGER_SEND_TO_LOGGING_SERVICE=ON,-DSEL_LOGGER_SEND_TO_LOGGING_SERVICE=OFF,phosphor-logging"