summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2021-03-25 22:40:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-04-12 23:10:16 +0300
commit57e15b1d5cf7749e6bd01c3ef484689f4191d51e (patch)
treeb3c83e9288860ba87c90ca39437989a5065cae9f /meta-phosphor/recipes-support
parentdfcf32d1c2b9a3de7a0aaeddfe0aba2c1ec06a16 (diff)
downloadopenbmc-57e15b1d5cf7749e6bd01c3ef484689f4191d51e.tar.xz
meta-phosphor: use systemd_system_unitdir
This variable was added to bitbake.conf so lets use it. Using it is best pratice and enables things like alternative base_libdir paths. Change-Id: I181d12e02ca7918614dacec68bd8e033932eb0ab Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-support')
-rw-r--r--meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb4
-rw-r--r--meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend6
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb b/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
index 5fcfeea174..596c1824f9 100644
--- a/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
+++ b/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
@@ -49,8 +49,8 @@ do_install_append() {
sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_unitdir}/system
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_system_unitdir}
}
inherit update-rc.d systemd
diff --git a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
index ce5d7994b4..e9577eb5de 100644
--- a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
+++ b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
@@ -8,7 +8,7 @@ PACKAGECONFIG_remove = "\
inherit systemd
-FILES_${PN} += "${systemd_unitdir}/system/rngd.service.d"
+FILES_${PN} += "${systemd_system_unitdir}/rngd.service.d"
do_install_append() {
@@ -18,9 +18,9 @@ do_install_append() {
# go slower.
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
if ${@bb.utils.contains('PACKAGECONFIG', 'libjitterentropy', 'true', 'false', d)}; then
- install -d ${D}${systemd_unitdir}/system/rngd.service.d
+ install -d ${D}${systemd_system_unitdir}/rngd.service.d
install -m 644 ${WORKDIR}/10-nice.conf \
- ${D}${systemd_unitdir}/system/rngd.service.d
+ ${D}${systemd_system_unitdir}/rngd.service.d
fi
fi
}