summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-x86/libpeci
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-x86/libpeci
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-x86/libpeci')
-rw-r--r--meta-phosphor/recipes-x86/libpeci/libpeci_git.bb14
1 files changed, 6 insertions, 8 deletions
diff --git a/meta-phosphor/recipes-x86/libpeci/libpeci_git.bb b/meta-phosphor/recipes-x86/libpeci/libpeci_git.bb
index 78d40f08f1..a5033f7471 100644
--- a/meta-phosphor/recipes-x86/libpeci/libpeci_git.bb
+++ b/meta-phosphor/recipes-x86/libpeci/libpeci_git.bb
@@ -1,17 +1,15 @@
SUMMARY = "PECI Library"
DESCRIPTION = "PECI Library"
-
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
-inherit cmake pkgconfig systemd
+SRCREV = "58dac1fdb2c4656f151509be4105ea0be3ab1988"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[dbus-raw-peci] = "-DDBUS_RAW_PECI=ON,-DDBUS_RAW_PECI=OFF,boost sdbusplus"
+PV = "0.1+git${SRCPV}"
SRC_URI = "git://github.com/openbmc/libpeci;branch=master;protocol=https"
-PV = "0.1+git${SRCPV}"
-SRCREV = "58dac1fdb2c4656f151509be4105ea0be3ab1988"
-
S = "${WORKDIR}/git"
-
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[dbus-raw-peci] = "-DDBUS_RAW_PECI=ON,-DDBUS_RAW_PECI=OFF,boost sdbusplus"
SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'dbus-raw-peci', 'com.intel.peci.service', '', d)}"
+
+inherit cmake pkgconfig systemd