summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <openbmcbump-github@yahoo.com>2023-10-03 09:30:20 +0300
committerWilly Tu <wltu@google.com>2023-10-18 19:30:20 +0300
commit38f200f4681f0d780fbef1e2b7418ac2b33c8463 (patch)
tree2d756d9e0f1bf8fba263a768e9d449e084555828 /meta-phosphor
parentff397ea4e4241f7a92f7e96f3db99273657b3812 (diff)
downloadopenbmc-38f200f4681f0d780fbef1e2b7418ac2b33c8463.tar.xz
obmc-console: Update PACKAGECONFIG for ssh
Enable PACKAGECONFIG to support `obmc-console-ssh` and make sure that it doens't conflict with concurrent-servers. Change-Id: I6c2205f827cdc74c32e4ce72ca2ce780a45d71bb Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com> Signed-off-by: Willy Tu <wltu@google.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/console/obmc-console_git.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
index f6043aebfd..e3b265ba45 100644
--- a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
@@ -7,9 +7,10 @@ DEPENDS += "autoconf-archive-native \
systemd \
"
SRCREV = "955d140e3caafb8a082a094d4fb6ebd2e3d7782a"
-PACKAGECONFIG ??= "udev"
+PACKAGECONFIG ??= "udev ssh"
PACKAGECONFIG[udev] = "-Dudev=enabled,-Dudev=disabled,udev"
PACKAGECONFIG[concurrent-servers] = "-Dconcurrent-servers=true,-Dconcurrent-servers=false,"
+PACKAGECONFIG[ssh] = "-Dssh=enabled,-Dssh=disabled"
PV = "1.0+git${SRCPV}"
PR = "r1"
@@ -18,10 +19,14 @@ SRC_URI += "file://${BPN}.conf"
SRC_URI += "file://dropbear.env"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE:${PN} += "obmc-console-ssh@.service \
- obmc-console-ssh.socket \
- obmc-console@.service \
- "
+SYSTEMD_SERVICE:${PN} += " obmc-console@.service"
+
+# Include ssh service if `ssh` is in PACKAGECONFIG.
+# Only install the ssh socket if we are not enabling
+# `concurrent-servers` in PACKAGECONFIG.
+SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'ssh', 'obmc-console-ssh@.service', '', d)}"
+SSH_SYSTEMD_SOCKET = "${@bb.utils.contains('PACKAGECONFIG', 'ssh', 'obmc-console-ssh.socket', '', d)}"
+SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'concurrent-servers', '', '${SSH_SYSTEMD_SOCKET}', d)}"
inherit meson pkgconfig
inherit obmc-phosphor-discovery-service