summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-04-16 22:14:26 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-04-23 02:48:03 +0300
commit60c4907f61898cdcfac80232a7dfcf4314a0a7d7 (patch)
treea53135a08a1cc84a08ccfde9b55543b809b09b1e /meta-phosphor
parent8ace09cd6c88708b0aa886993d3586f2f46eceee (diff)
downloadopenbmc-60c4907f61898cdcfac80232a7dfcf4314a0a7d7.tar.xz
phosphor-logging: remove native recipe support
phosphor-logging use to need to run in a native context to provide YAML processing but that is no longer necessary since commit e523a091d0977adf639eaa7cdf4f895614d2696c. The support to install just the python scripts in a native context overly complicates both the recipe and the corresponding repository build scripting. Remove it since it is no longer needed. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I67542f8f63bf9e30166ac1ab46eb85074cf3e843
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/classes/phosphor-logging.bbclass1
-rw-r--r--meta-phosphor/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend1
-rw-r--r--meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb43
3 files changed, 2 insertions, 43 deletions
diff --git a/meta-phosphor/classes/phosphor-logging.bbclass b/meta-phosphor/classes/phosphor-logging.bbclass
index 48676f4ff2..18f53d4347 100644
--- a/meta-phosphor/classes/phosphor-logging.bbclass
+++ b/meta-phosphor/classes/phosphor-logging.bbclass
@@ -1,2 +1 @@
callouts_datadir="${datadir}/phosphor-logging/callouts"
-elog_dir = "${datadir}/phosphor-logging/elog"
diff --git a/meta-phosphor/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend b/meta-phosphor/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
index e111a4d959..b8648cabff 100644
--- a/meta-phosphor/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
+++ b/meta-phosphor/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
@@ -2,5 +2,4 @@ RDEPENDS_${PN}_append = " \
nativesdk-autoconf-archive \
nativesdk-meson \
nativesdk-python3-sdbus++ \
- nativesdk-phosphor-logging-elog \
"
diff --git a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
index 701c1632c0..bb6f0a9369 100644
--- a/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/meta-phosphor/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -24,14 +24,11 @@ DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "virtual/phosphor-logging-callouts"
DEPENDS += "libcereal"
DEPENDS += "sdeventplus"
-DEPENDS_append_class-target = " packagegroup-obmc-yaml-providers"
+DEPENDS += "packagegroup-obmc-yaml-providers"
PACKAGE_BEFORE_PN = "${PN}-test"
FILES_${PN}-test = "${bindir}/*-test"
-PACKAGE_BEFORE_PN += "${PN}-elog"
-FILES_${PN}-elog += "${elog_dir}"
-
# Package configuration
LOGGING_PACKAGES = " \
${PN}-base \
@@ -59,40 +56,13 @@ SRCREV = "7dc8c3bea5747b430b7df2eea891f9df1169f23a"
S = "${WORKDIR}/git"
-# Do not DEPEND on the specified packages for native build
-# as they will not be available in host machine
-DEPENDS_remove_class-native = " \
- virtual/phosphor-logging-callouts \
- sdbusplus \
- systemd \
- libcereal \
- sdeventplus \
- "
-
-# Do not DEPEND on the specified packages for native SDK build
-# as they will not be available in host machine
-DEPENDS_remove_class-nativesdk = " \
- virtual/phosphor-logging-callouts \
- sdbusplus \
- libcereal \
- systemd \
- phosphor-dbus-interfaces \
- sdeventplus \
- "
-
-PACKAGECONFIG ??= "metadata-processing install_scripts"
+PACKAGECONFIG ??= "metadata-processing"
PACKAGECONFIG[metadata-processing] = " \
--enable-metadata-processing, \
--disable-metadata-processing, , \
"
-# Provide a means to enable/disable install_scripts feature
-PACKAGECONFIG[install_scripts] = " \
- --enable-install_scripts, \
- --disable-install_scripts, ,\
- "
-
PACKAGECONFIG[openpower-pels] = " \
--enable-openpower-pel-extension, \
--disable-openpower-pel-extension, \
@@ -100,16 +70,7 @@ PACKAGECONFIG[openpower-pels] = " \
python3, \
"
-# Enable install_scripts during native and native SDK build
-PACKAGECONFIG_add_class-native = "install_scripts"
-PACKAGECONFIG_add_class-nativesdk = "install_scripts"
-
-# Disable install_scripts during target build
-PACKAGECONFIG_remove_class-target = "install_scripts"
-
EXTRA_OECONF = " \
YAML_DIR=${STAGING_DIR_TARGET}${yaml_dir} \
CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
"
-
-BBCLASSEXTEND += "native nativesdk"