summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2023-10-19 16:22:24 +0300
committerAndrew Geissler <geissonator@yahoo.com>2023-10-20 16:35:32 +0300
commit98d6d6376a752b30f8068b3b906d76a2bbbb55b7 (patch)
tree7b65b69a3d1e2d4a669ff7c9c6fa2b85abe9451c /meta-phosphor
parentb0122d1f4ae1250fb9d68265d91c148e61c6f171 (diff)
downloadopenbmc-98d6d6376a752b30f8068b3b906d76a2bbbb55b7.tar.xz
phosphor-gpio-monitor: provide default multi json
The service is installed by default so ensure there is an empty json file for it to find. Tested: - Confirmed service loads empty file and exits without error Change-Id: I757053064606e05167b1f0a32113373fcc322214 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json1
-rw-r--r--meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor_git.bb7
2 files changed, 8 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json b/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json
new file mode 100644
index 0000000000..fe51488c70
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json
@@ -0,0 +1 @@
+[]
diff --git a/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor_git.bb b/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor_git.bb
index 54aed10af0..ba97d7eba3 100644
--- a/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor_git.bb
+++ b/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor_git.bb
@@ -17,6 +17,7 @@ PV = "1.0+git${SRCPV}"
PR = "r1"
SRC_URI = "git://github.com/openbmc/phosphor-gpio-monitor;branch=master;protocol=https"
+SRC_URI += " file://phosphor-multi-gpio-presence.json"
SYSTEMD_PACKAGES = "${GPIO_PACKAGES}"
SYSTEMD_SERVICE:${PN}-monitor += "phosphor-multi-gpio-monitor.service"
@@ -36,6 +37,7 @@ FILES:${PN}-monitor += "${bindir}/phosphor-gpio-util"
FILES:${PN}-monitor += "${nonarch_base_libdir}/udev/rules.d/99-gpio-keys.rules"
FILES:${PN}-presence += "${bindir}/phosphor-gpio-presence"
FILES:${PN}-presence += "${bindir}/phosphor-multi-gpio-presence"
+FILES:${PN}-presence += "${datadir}/${PN}/phosphor-multi-gpio-presence.json"
ALLOW_EMPTY:${PN} = "1"
@@ -44,3 +46,8 @@ GPIO_PACKAGES = " \
${PN}-presence \
"
PACKAGE_BEFORE_PN += "${GPIO_PACKAGES}"
+
+do_install:append() {
+ install -d ${D}${datadir}/phosphor-gpio-monitor/
+ install -m 0644 ${WORKDIR}/phosphor-multi-gpio-presence.json ${D}${datadir}/${PN}/
+}