summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-10-13 18:05:58 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-10-14 12:42:09 +0300
commit9e7501c12ea79e07a714c482c8d9e1d66fdf95a1 (patch)
treeed673efb01a0cfba09ea598b50ae3358e0662b0b /meta-phosphor
parent4c4a78dff55b805e5ffb87a7bcaaec94a3277984 (diff)
downloadopenbmc-9e7501c12ea79e07a714c482c8d9e1d66fdf95a1.tar.xz
meta-phosphor: remove avahi upgrade workaround
A workaround was added in 2019 to handle code updates, which needed to add an avahi user. Assume that this has been applied to all vendor machines by now and can be removed. Tested: Booted Witherspoon in QEMU and observe the avahi user and group are still created correctly. ``` root@witherspoon:~# grep avahi /etc/group /etc/passwd /etc/group:avahi:x:996: /etc/passwd:avahi:x:997:996::/run/avahi-daemon:/bin/false ``` Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I704dd7f09803df32690ba37882e94bb0664597e5
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-connectivity/avahi/avahi-daemon/avahi-daemon-override.conf3
-rw-r--r--meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend10
2 files changed, 0 insertions, 13 deletions
diff --git a/meta-phosphor/recipes-connectivity/avahi/avahi-daemon/avahi-daemon-override.conf b/meta-phosphor/recipes-connectivity/avahi/avahi-daemon/avahi-daemon-override.conf
deleted file mode 100644
index 9a594c6e1c..0000000000
--- a/meta-phosphor/recipes-connectivity/avahi/avahi-daemon/avahi-daemon-override.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-[Service]
-ExecStartPre=/bin/sh -c "grep -q avahi: /etc/group || /usr/sbin/addgroup --system avahi"
-ExecStartPre=/bin/sh -c "grep -q avahi: /etc/passwd || /usr/sbin/adduser --system --no-create-home --ingroup avahi avahi"
diff --git a/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
deleted file mode 100644
index 5986ac0811..0000000000
--- a/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/avahi-daemon:"
-
-SRC_URI += "file://avahi-daemon-override.conf"
-
-do_install:append() {
- install -m 644 -D ${WORKDIR}/avahi-daemon-override.conf \
- ${D}${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf
-}
-
-FILES:avahi-daemon:append = " ${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf"