summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-common
diff options
context:
space:
mode:
authorAlan Kuo <Alan_Kuo@quantatw.com>2020-12-23 05:19:30 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-01-08 22:13:50 +0300
commit4042cacca8bf0c392d0d9f88f4a3e99bf5b7ff50 (patch)
tree66850106226fd51739158497c1385aa0cffe1b3f /meta-quanta/meta-common
parent60a2f202f2ae9a9b468d447a5aa6f4d575e9b45d (diff)
downloadopenbmc-4042cacca8bf0c392d0d9f88f4a3e99bf5b7ff50.tar.xz
Revert "meta-quanta: meta-common: enable TLS with static CA and specific user"
This reverts commit a310726a27974a471386d4e5f6d4b79f3bc6906e. Reason for revert: - Remove Feature: 1. The feature that only enable mTLS authentication will be moved to bmcweb, which can be controlled by the meson options of bmcweb 2. phosphor-monitor-hostname will move into bmcweb - The remaining features are moved to meta-google 1. default-users 2. default-ca (From meta-quanta rev: 535e6926336f229686e71f7617bd4e0ac28b61dc) Signed-off-by: Alan Kuo <Alan_Kuo@quantatw.com> Change-Id: I5213668928db866b54206732cab8747510e63607 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-quanta/meta-common')
-rwxr-xr-xmeta-quanta/meta-common/recipes-quanta/default-users/default-users.bb24
-rw-r--r--meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls.bb22
-rw-r--r--meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls/bmcweb_persistent_data.json1
-rwxr-xr-xmeta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls/certs/authority/Quanta_CA.crt22
-rwxr-xr-xmeta-quanta/meta-common/recipes-quanta/monitor-hostname/phosphor-monitor-hostname_git.bb22
5 files changed, 0 insertions, 91 deletions
diff --git a/meta-quanta/meta-common/recipes-quanta/default-users/default-users.bb b/meta-quanta/meta-common/recipes-quanta/default-users/default-users.bb
deleted file mode 100755
index 0bb9be8215..0000000000
--- a/meta-quanta/meta-common/recipes-quanta/default-users/default-users.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-SUMMARY = "Add default Users"
-DESCRIPTION = "Add Users"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-EXCLUDE_FROM_WORLD = "1"
-
-DEPENDS = "bmcweb"
-DEPENDS += "phosphor-ipmi-host"
-DEPENDS += "phosphor-user-manager"
-RDEPENDS_${PN} = "bmcweb"
-RDEPENDS_${PN} += "phosphor-ipmi-host"
-RDEPENDS_${PN} += "phosphor-user-manager"
-
-inherit useradd
-USERADD_PACKAGES = "${PN}"
-
-USERADD_PARAM_${PN} = "-m -N -u 1000 -g 100 -s /bin/nologin \
- -p '\$1\$UGMqyqdG\$FZiylVFmRRfl9Z0Ue8G7e/' \
- -G 'web,redfish,priv-admin' Megapede; "
-GROUPMEMS_PARAM_${PN} = "-g priv-admin -a root; "
-GROUPMEMS_PARAM_${PN} += "-g ipmi -a root; "
-
-ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls.bb b/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls.bb
deleted file mode 100644
index fca483e11b..0000000000
--- a/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "Enable TLS with static CA"
-DESCRIPTION = "Add static CA and only enable TLS authentication"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://certs/authority/ \
- file://bmcweb_persistent_data.json \
- "
-do_install(){
- install -d ${D}${sysconfdir}/ssl/certs/authority
- install -m 0644 -D ${WORKDIR}/certs/authority/* \
- ${D}${sysconfdir}/ssl/certs/authority
-
- install -d ${D}${ROOT_HOME}
- install -m 0640 ${WORKDIR}/bmcweb_persistent_data.json ${D}${ROOT_HOME}
-}
-
-FILES_${PN} = "${ROOT_HOME}/bmcweb_persistent_data.json \
- ${sysconfdir}/ssl/certs/authority/* \
- "
diff --git a/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls/bmcweb_persistent_data.json b/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls/bmcweb_persistent_data.json
deleted file mode 100644
index aa50152687..0000000000
--- a/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls/bmcweb_persistent_data.json
+++ /dev/null
@@ -1 +0,0 @@
-{"auth_config":{"BasicAuth":false,"Cookie":false,"SessionToken":false,"TLS":true,"XToken":false}}
diff --git a/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls/certs/authority/Quanta_CA.crt b/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls/certs/authority/Quanta_CA.crt
deleted file mode 100755
index 77e5b2c9b5..0000000000
--- a/meta-quanta/meta-common/recipes-quanta/enable-tls/enable-tls/certs/authority/Quanta_CA.crt
+++ /dev/null
@@ -1,22 +0,0 @@
------BEGIN CERTIFICATE-----
-MIIDkDCCAnigAwIBAgIIRnUufKw0mL8wDQYJKoZIhvcNAQELBQAwPTELMAkGA1UE
-BhMCVFcxDzANBgNVBAoTBlF1YW50YTELMAkGA1UECxMCQ0ExEDAOBgNVBAMTB09w
-ZW5CTUMwHhcNMjAwMTAxMDAwMDAwWhcNMzYxMjMxMjM1OTU5WjA9MQswCQYDVQQG
-EwJUVzEPMA0GA1UEChMGUXVhbnRhMQswCQYDVQQLEwJDQTEQMA4GA1UEAxMHT3Bl
-bkJNQzCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBANyBHOcnaVt4K1lt
-msTmFzIBf1sI/HV7XW6VMICOOESUv/vrMxCNOzhil4J+CWpFjwkk8zGK6tiLXmMe
-3/oa6qqHN0GXd7XoyBn3XRrr/L2gKipUsWlYk43Wq0TX2ugEcCWqOr0Ol4TcuD4Z
-+pswkgHxqJtbfiWd1sTKpbCvjbnlN9EKir52DRZie0m8ANIbTp/KPVmY+UAU7Vz/
-QpYemolsrwupzWJbz34jC2rnNw8HFBHIMyNLJVocUkCVYy5ka0dRk+APC3VWX4C6
-1GmUd4ZQZs4LayyfQcK3Tb+PkNCf9AxBE8eId0lHpufq2Uhml1Lwrfh/1TObCwkW
-ufgv6HsCAwEAAaOBkzCBkDAPBgNVHRMBAf8EBTADAQH/MB0GA1UdDgQWBBTpEhTE
-nCIZo7dCDFtqUjMRcOI9SDAfBgNVHSMEGDAWgBTpEhTEnCIZo7dCDFtqUjMRcOI9
-SDALBgNVHQ8EBAMCAb4wHQYDVR0lBBYwFAYIKwYBBQUHAwEGCCsGAQUFBwMCMBEG
-CWCGSAGG+EIBAQQEAwIAxzANBgkqhkiG9w0BAQsFAAOCAQEAaw2to4hiADeZO/WF
-UMxrKjB4mbpHOb8cn3HIBIkrE6XxpH6T9MaZh7xi7kyyiuVNGh70lh+qxBUmVf5B
-OF2NSF6ffDrW86dMNV+tKlByHElUqWFcWgU1XFipcN7u0aeFkfPsqG4BwcZlBUEN
-rr9GDFNNadmjnoVA3deVTu4kHTVz6vg0vJExDfBHhNBWsLzLizRIebv9jumJlHPl
-I99czz3NQKVjm8z/BlWaMxpWU/bLxL2Aq/6rQ0iCoeIPJqHubG1CmGwI7k9ZQTUh
-VAMKR4W7JAul+CK8oEC7TAVU2L2fk6g+eSwU12HgO+IUOXmdp3bPtGkk73wG4iOj
-hN2Bow==
------END CERTIFICATE-----
diff --git a/meta-quanta/meta-common/recipes-quanta/monitor-hostname/phosphor-monitor-hostname_git.bb b/meta-quanta/meta-common/recipes-quanta/monitor-hostname/phosphor-monitor-hostname_git.bb
deleted file mode 100755
index 99d11d1734..0000000000
--- a/meta-quanta/meta-common/recipes-quanta/monitor-hostname/phosphor-monitor-hostname_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "Quanta Monitor HostName Service"
-DESCRIPTION = "Quanta Monitor HostName Service"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-inherit cmake systemd
-
-DEPENDS += " \
- boost \
- sdbusplus \
- "
-
-SRC_URI += "git://github.com/quanta-bmc/phosphor-monitor-hostname"
-SRCREV := "1172ec20f8dd41d18519c2cb3ae59bbde5acd634"
-S = "${WORKDIR}/git"
-
-SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.MonitorHostname.service"
-
-
-