summaryrefslogtreecommitdiff
path: root/meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb
diff options
context:
space:
mode:
authorDavid Wang <davidwang@quantatw.com>2021-08-13 06:39:20 +0300
committerDavid Wang <davidwang@quantatw.com>2021-08-13 12:36:23 +0300
commit026925dd6641c96768d9636b6114acbfcdb8579f (patch)
treecdec2edbb3b471b1bd83f621a3983c6440dfe3cd /meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb
parentca3e1d9f86212282ca59f384055497eb0d156d49 (diff)
downloadopenbmc-026925dd6641c96768d9636b6114acbfcdb8579f.tar.xz
meta-quanta: Cleanup for Yocto override syntax change
- Cleanup subtree meta-f0b, meta-olympus-nuvoton, meta-q71l with convert-overrides.py meta-quanta/meta-f0b convert-overrides.py meta-quanta/meta-olympus-nuvoton convert-overrides.py meta-quanta/meta-q71l git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-f0b git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-olympus-nuvoton git grep "_[a-z0-9_/-]*[ :]" -- meta-quanta/meta-q71l git grep -l _f0b -- meta-quanta/meta-f0b | xargs sed -i 's/_f0b/:f0b/' git grep -l _olympus-nuvoton -- meta-quanta/meta-olympus-nuvoton | xargs sed -i 's/_olympus-nuvoton/:olympus-nuvoton/' git grep -l _quanta-q71l -- meta-quanta/meta-q71l | xargs sed -i 's/_quanta-q71l/:quanta-q71l/' - Fix up a few by hand - Revert 'BBFILE_PATTERN' and 'LAYERSERIES_COMPAT' - Add honister to 'LAYERSERIES_COMPAT' - Update 'CONF_VERSION' - Fix up 'SYSTEMD_ENVIRONMENT_FILE', 'SYSTEMD_LINK' and 'SYSTEMD_OVERRIDE' in all subtree Signed-off-by: David Wang <davidwang@quantatw.com> Change-Id: Ic431624d09dc5899b1d84439559bea9efca08ad8
Diffstat (limited to 'meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb')
-rw-r--r--meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb b/meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb
index 37b27ac695..a5403556d7 100644
--- a/meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb
+++ b/meta-quanta/meta-q71l/recipes-phosphor/quanta-powerctrl/quanta-powerctrl.bb
@@ -1,11 +1,11 @@
-FILESEXTRAPATHS_append := "${THISDIR}/files:"
+FILESEXTRAPATHS:append := "${THISDIR}/files:"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
inherit systemd
inherit obmc-phosphor-systemd
-S = "${WORKDIR}/"
+S = "${WORKDIR}"
SRC_URI = "file://init_once.sh \
file://poweroff.sh \
@@ -15,10 +15,10 @@ SRC_URI = "file://init_once.sh \
file://host-poweron.service"
DEPENDS = "systemd"
-RDEPENDS_${PN} = "bash"
+RDEPENDS:${PN} = "bash"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
+SYSTEMD_SERVICE:${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
do_install() {
install -d ${D}/${bindir}