summaryrefslogtreecommitdiff
path: root/meta-quanta
diff options
context:
space:
mode:
authorFranHsu <Fran.Hsu@quantatw.com>2019-03-27 06:30:14 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-09 02:43:00 +0300
commitb3331fa8d75fbc54ef020e30bb69af0f5d0e305e (patch)
treed95f38e1e383b849e183331dc558191668667ff3 /meta-quanta
parente11476a1a06807f0f8f736e72f0d252123dc2208 (diff)
downloadopenbmc-b3331fa8d75fbc54ef020e30bb69af0f5d0e305e.tar.xz
quanta: update gsj machine configuration
Commit GSJ project configurations. 1. Add configuration for u-boot-evn. 2. Update kernel configuration. 3. Add gsj suffix to some properties. Tested: Build Quanta GSJ image and load on the GSJ BMC module. Ensure that BMC boots to console successfully. (From meta-quanta rev: fc91a4374e2576e940f9c70f34cfe5af9d0aa727) Change-Id: I2de3b60db65f744bdc1a573efd063b999aa2536e Signed-off-by: Fran Hsu <Fran.Hsu@quantatw.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-quanta')
-rw-r--r--meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config24
-rw-r--r--meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend7
-rw-r--r--meta-quanta/meta-gsj/recipes-kernel/linux/linux-nuvoton/gsj.cfg14
3 files changed, 45 insertions, 0 deletions
diff --git a/meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config b/meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config
new file mode 100644
index 0000000000..0c384273f2
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton/fw_env.config
@@ -0,0 +1,24 @@
+# Configuration file for fw_(printenv/setenv) utility.
+# Up to two entries are valid, in this case the redundant
+# environment sector is assumed present.
+# Notice, that the "Number of sectors" is not required on NOR and SPI-dataflash.
+# Futhermore, if the Flash sector size is ommitted, this value is assumed to
+# be the same as the Environment size, which is valid for NOR and SPI-dataflash
+
+# NOR example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+/dev/mtd2 0x0000 0x40000 0x4000
+
+# MTD SPI-dataflash example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+#/dev/mtd5 0x4200 0x4200
+#/dev/mtd6 0x4200 0x4200
+
+# NAND example
+#/dev/mtd0 0x4000 0x4000 0x20000 2
+
+# Block device example
+#/dev/mmcblk0 0xc0000 0x20000
+
+# VFAT example
+#/boot/uboot.env 0x0000 0x4000
diff --git a/meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend b/meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
new file mode 100644
index 0000000000..c5aea4089b
--- /dev/null
+++ b/meta-quanta/meta-gsj/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend_gsj := "${THISDIR}/${PN}:"
+
+SRC_URI_append_gsj = " file://fw_env.config"
+
+do_install_append_gsj () {
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}
diff --git a/meta-quanta/meta-gsj/recipes-kernel/linux/linux-nuvoton/gsj.cfg b/meta-quanta/meta-gsj/recipes-kernel/linux/linux-nuvoton/gsj.cfg
index 9435516b49..d498a2bb06 100644
--- a/meta-quanta/meta-gsj/recipes-kernel/linux/linux-nuvoton/gsj.cfg
+++ b/meta-quanta/meta-gsj/recipes-kernel/linux/linux-nuvoton/gsj.cfg
@@ -46,3 +46,17 @@ CONFIG_USB_CONFIGFS_RNDIS=y
CONFIG_USB_CONFIGFS_EEM=y
CONFIG_USB_CONFIGFS_MASS_STORAGE=y
CONFIG_USB_CONFIGFS_F_HID=y
+
+CONFIG_MEDIA_SUPPORT=y
+CONFIG_FORCE_MAX_ZONEORDER=12
+CONFIG_SENSORS_LM25066=y
+CONFIG_I2C_SLAVE=y
+CONFIG_I2C_SLAVE_MQUEUE=y
+CONFIG_NUVOTON_JTAG=y
+CONFIG_EDAC_ATOMIC_SCRUB=y
+CONFIG_EDAC_SUPPORT=y
+CONFIG_EDAC=y
+CONFIG_EDAC_LEGACY_SYSFS=y
+CONFIG_EDAC_DEBUG=y
+CONFIG_EDAC_NPCM7XX=y
+CONFIG_RAS=y