summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-16 17:06:00 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-16 17:06:13 +0300
commit1b9ee2930ed85e998a455a6149e2592a83609443 (patch)
treecc13fad7c07cdcd0532fcfd22482a4c00b558512 /meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
parente42b3e385822fc1b08807a585d4bb2015c823690 (diff)
downloadopenbmc-1b9ee2930ed85e998a455a6149e2592a83609443.tar.xz
meta-raspberrypi: subtree update:a953fc0f9b..e7c856ee7b
Allen Wild (1): conf/machine: add pci to MACHINE_FEATURES for Pi4 Andrei Gherzan (3): pi-bluetooth: Fix signature failures raspberrypi-tools: Update to current HEAD armstubs: Define the new symbols use in Makefile Erik Botö (1): Add support for PiTFT 2.8" with capacitive touch Martin Jansa (1): gstreamer1.0-plugins-base: respect opengl DISTRO_FEATURES when vc4graphics is in MACHINE_FEATURES Pierre-Jean Texier (1): linux-raspberrypi: bump to Linux version 4.19.93 Ricardo Salveti (2): linux-raspberrypi: define kbuild defconfig for rpi cm3 raspberrypi-cm3.conf: drop KBUILD_DEFCONFIG definition Change-Id: Ie923657098eaf9733c7f6f73ee1f888174d44e5f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb')
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index 160bc16d0a..5315676fdf 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -20,6 +20,7 @@ INHIBIT_DEFAULT_DEPS = "1"
PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
PITFT22="${@bb.utils.contains("MACHINE_FEATURES", "pitft22", "1", "0", d)}"
PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}"
+PITFT28c="${@bb.utils.contains("MACHINE_FEATURES", "pitft28c", "1", "0", d)}"
PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}"
VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
@@ -144,6 +145,11 @@ do_deploy() {
echo "# Enable PITFT28r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi
+ if [ "${PITFT28c}" = "1" ]; then
+ echo "# Enable PITFT28c display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=pitft28-capacitive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=pitft28-capacitive,touch-swapxy,touch-invx" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
if [ "${PITFT35r}" = "1" ]; then
echo "# Enable PITFT35r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt