summaryrefslogtreecommitdiff
path: root/meta-security/classes/dm-verity-img.bbclass
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2023-03-03 21:38:41 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-03-17 01:00:33 +0300
commit9347dd4efc156c93b1d9beaeb32e9b719ad6a3d2 (patch)
tree00c3e91a451670569716e087a5df52de1e838c21 /meta-security/classes/dm-verity-img.bbclass
parenta2acbee53923f9aa6d5f914b6d7cc7a80da2cea9 (diff)
downloadopenbmc-9347dd4efc156c93b1d9beaeb32e9b719ad6a3d2.tar.xz
subtree updates: raspberrypi security arm
meta-raspberrypi: e43af1e3a6..e15b876155: Florian Frank (1): linux-firmware-rpidistro: Fix wireless on model 3B and Zero W Khem Raj (1): linux-raspberrypi_5.15.bb: Upgrade to 5.15.92 Martin Jansa (1): gstreamer1.0-plugins-good: rename bbappend, drop version meta-arm: dc10b73cc5..eb9c47a4e1: Gowtham Suresh Kumar (6): arm/edk2-basetools: Add edk2 base tool native recipe arm-bsp/uefi_capsule: Add UEFI capsule generation class arm-bsp/corstone1000-image: Generate UEFI capsule for corstone1000 platform arm/edk2-basetools: Convert edk2 basetools recipes to native only arm-bsp/uefi_capsule: Use json file to pass capsule config arm/uefi_capsule: Move UEFI capsule to IMGDEPLOYDIR Jon Mason (5): arm/boot-wrapper-aarch64: update to a newer SHA arm/gn: update to a more recent SHA arm/opencsd: update to v1.4.0 arm/trusted-firmware-a: update version and relocate fiptool arm/sbsa-acs: update to v6.1.0 Mohamed Omar Asaker (5): arm-bsp/trusted-services: corstone1000:Align psa crypto client with TF-Mv1.7 arm-bsp/trusted-services:corstone1000: disable obsolete algorithms for crypto arm-bsp/trusted-services: corstone1000: Disable SHA512/384 arm-bsp/trusted-firmware-m:corstone1000: Increase number of assets arm-bsp/trusted-firmware-m:corstone1000: Set SPM backend to IPC Peter Hoyes (11): arm,arm-bsp/classes: Move wic_nopt to meta-arm arm-bsp/classes: Use :append to add to IMAGE_TYPES in wic_nopt CI: Factor out CACHE_DIR to improve mirror configurability CI: Collect testimage logs on failure arm/trusted-firmware-m: Synchronize with 1.7.0 release arm/classes: Factor out image signing arguments in tfm_image_sign arm/trusted-firmware-m: Create common inc file for src definitions arm/trusted-firmware-m: Create inc file for common config arm/trusted-firmware-m-scripts: Create inc file for common config arm/classes: Add sstate support to tfm_sign_images CI: Add BUILD_ENABLE_REGEX option to conditionally enable builds Ross Burton (8): arm-bsp/external-system: fix the gen_module race, again arm-bsp/linux-yocto: add 5.19 kernel recipe for N1SDP arm/linux-yocto: remove obsolete 5.19 bbappend arm/trusted-firmware-m: Do not use release branches arm/boot-wrapper-aarch64: tell upgrade checker to look for new SHAs CI/machine-summary: add missing recipes arm-toolchain/gcc-arm: add missing Signed-off-by tag arm/optee-os: add missing patch header meta-security: 3529cfb43e..c06b9a18a6: Maciej Borzęcki (1): dm-verity-img.bbclass: add squashfs images Petr Gotthard (4): tpm2-tss: upgrade 3.2.0 -> 4.0.1 tpm2-tools: upgrade 5.3 -> 5.5 tpm2-pkcs11: upgrade 1.8.0 -> 1.9.0 tpm2-abrmd: upgrade 2.4.1 -> 3.0.0 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I0e1629b2f70ad1e5f7b97f5ae6d768bde101cc6f
Diffstat (limited to 'meta-security/classes/dm-verity-img.bbclass')
-rw-r--r--meta-security/classes/dm-verity-img.bbclass7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-security/classes/dm-verity-img.bbclass b/meta-security/classes/dm-verity-img.bbclass
index dd447e661f..e5946bc327 100644
--- a/meta-security/classes/dm-verity-img.bbclass
+++ b/meta-security/classes/dm-verity-img.bbclass
@@ -63,7 +63,12 @@ verity_setup() {
veritysetup --data-block-size=${DM_VERITY_IMAGE_DATA_BLOCK_SIZE} --hash-offset=$SIZE format $OUTPUT $OUTPUT | tail -n +2 | process_verity
}
-VERITY_TYPES = "ext2.verity ext3.verity ext4.verity btrfs.verity erofs.verity erofs-lz4.verity erofs-lz4hc.verity"
+VERITY_TYPES = " \
+ ext2.verity ext3.verity ext4.verity \
+ btrfs.verity \
+ erofs.verity erofs-lz4.verity erofs-lz4hc.verity \
+ squashfs.verity squashfs-xz.verity squashfs-lzo.verity squashfs-lz4.verity squashfs-zst.verity \
+"
IMAGE_TYPES += "${VERITY_TYPES}"
CONVERSIONTYPES += "verity"
CONVERSION_CMD:verity = "verity_setup ${type}"