summaryrefslogtreecommitdiff
path: root/meta-security
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-01-30 22:28:01 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-01-30 23:15:34 +0300
commitb9af8750acfaddd4a8b99c3e289510b5476c90f3 (patch)
tree53385dd5fc99ccf4869c9c80fcd1e98e100fe81f /meta-security
parent70d69cd8440d2a940a971f262a3e36cc78781461 (diff)
downloadopenbmc-b9af8750acfaddd4a8b99c3e289510b5476c90f3.tar.xz
subtree updates
meta-security: 3d9dab6d14..7eed4a60f5: Armin Kuster (2): linux-yocto.bbappend: bump to kernel version 6.x meta-tpm: bump linux-yocto to 6.x kernel Max Krummenacher (1): samhain: rework due to changed cache handling meta-openembedded: 2ab113e8be..ea63f13846: Beniamin Sandu (1): mbedtls: export source files/headers needed by ATF Khem Raj (13): poco: Do not use std::atomic<bool> libwebsockets: Fix build with gcc13 v4l-utils: Fix build with gcc13 proj: Upgrade to 9.1.1 release mpd: Upgrade to 0.23.12 release geos: Upgrade to 3.9.4 geos: Fix build with gcc13 libinih: Upgrade to version 56 python3-pybind11: Upgrade to 2.10.3 waylandpp: Fix build with gcc-13 sedutil: Fix build with gcc13 usbguard: Fix build with gcc13 minifi-cpp: Fix build with gcc13 Martin Jansa (6): keyutils: fix Upstream-Status formatting gphoto2: fix Upstream-Status formatting .patch: fix Upstream-Status formatting issues reported by patchreview tool from oe-core android-tools: fix Upstream-Status formatting mm-common: fix Upstream-Status formatting .patch: fix Signed-off-by formatting issues reported by patchreview tool from oe-core poky: 5e249ec855..29afbb5e14: Alejandro Hernandez Samaniego (1): newlib: Upgrade 4.2.0 -> 4.3.0 Alexander Kanavin (1): gdk-pixbuf: do not use tools from gdk-pixbuf-native when building tests Armin Kuster (1): lttng-modules: Fix for 5.10.163 kernel version Khem Raj (3): valgrind: Include missing <cstdint> webkitgtk: Fix build with gcc 13 gdb: Define alignof using _Alignof when using C11 or newer Richard Purdie (3): make-mod-scripts: Ensure kernel build output is deterministic bitbake.conf: Inject a dash into PN for BB_HASH_CODEPARSER_VALS scripts/bitbake-prserv-tool: Fix to work with memres bitbake Ross Burton (1): Revert "cve-update-db-native: show IP on failure" meta-arm: 3d51e1117d..aecbb77f72: Jon Mason (4): arm/qemuarm-secureboot: Changes for v2023.01 u-boot arm-bsp/juno: update to use u-boot v2023.01 arm-bsp/juno: update kernel patches for 6.1 arm-bsp/fvp-base: update kernel config to remove warning Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ia335876b7ce9a4c9d19ca41ae321b266b3b6d00e
Diffstat (limited to 'meta-security')
-rw-r--r--meta-security/meta-tpm/recipes-kernel/linux/linux-yocto_6.%.bbappend (renamed from meta-security/meta-tpm/recipes-kernel/linux/linux-yocto_5.%.bbappend)0
-rw-r--r--meta-security/recipes-ids/samhain/samhain-client.bb3
-rw-r--r--meta-security/recipes-ids/samhain/samhain-server.bb3
-rw-r--r--meta-security/recipes-ids/samhain/samhain-standalone.bb3
-rw-r--r--meta-security/recipes-ids/samhain/samhain.inc8
-rw-r--r--meta-security/recipes-kernel/linux/linux-yocto_6.%.bbappend (renamed from meta-security/recipes-kernel/linux/linux-yocto_5.%.bbappend)0
6 files changed, 9 insertions, 8 deletions
diff --git a/meta-security/meta-tpm/recipes-kernel/linux/linux-yocto_5.%.bbappend b/meta-security/meta-tpm/recipes-kernel/linux/linux-yocto_6.%.bbappend
index e8027ff38d..e8027ff38d 100644
--- a/meta-security/meta-tpm/recipes-kernel/linux/linux-yocto_5.%.bbappend
+++ b/meta-security/meta-tpm/recipes-kernel/linux/linux-yocto_6.%.bbappend
diff --git a/meta-security/recipes-ids/samhain/samhain-client.bb b/meta-security/recipes-ids/samhain/samhain-client.bb
index 2b99e20169..0de9c344ab 100644
--- a/meta-security/recipes-ids/samhain/samhain-client.bb
+++ b/meta-security/recipes-ids/samhain/samhain-client.bb
@@ -8,5 +8,8 @@ EXTRA_OECONF += " \
--with-port=${SAMHAIN_PORT} \
"
+MODE_NAME = "client"
+SAMHAIN_MODE = "client"
+
RDEPENDS:${PN} = "acl zlib attr bash"
RCONFLICTS:${PN} = "samhain-standalone"
diff --git a/meta-security/recipes-ids/samhain/samhain-server.bb b/meta-security/recipes-ids/samhain/samhain-server.bb
index 51bce07cd1..8bae2d204b 100644
--- a/meta-security/recipes-ids/samhain/samhain-server.bb
+++ b/meta-security/recipes-ids/samhain/samhain-server.bb
@@ -8,6 +8,9 @@ SRC_URI += "file://samhain-server-volatiles \
file://samhain-server-volatiles.conf \
"
+MODE_NAME = "server"
+SAMHAIN_MODE = "server"
+
TARGET_CC_ARCH += "${LDFLAGS}"
do_install:append() {
diff --git a/meta-security/recipes-ids/samhain/samhain-standalone.bb b/meta-security/recipes-ids/samhain/samhain-standalone.bb
index b832dc84b9..ae9ed2b13b 100644
--- a/meta-security/recipes-ids/samhain/samhain-standalone.bb
+++ b/meta-security/recipes-ids/samhain/samhain-standalone.bb
@@ -7,6 +7,9 @@ SRC_URI += "file://samhain-not-run-ptest-on-host.patch \
PROVIDES += "samhain"
+MODE_NAME = "standalone"
+SAMHAIN_MODE = "no"
+
SYSTEMD_SERVICE:${PN} = "samhain.service"
inherit ptest
diff --git a/meta-security/recipes-ids/samhain/samhain.inc b/meta-security/recipes-ids/samhain/samhain.inc
index eb8592d34b..8967d722e0 100644
--- a/meta-security/recipes-ids/samhain/samhain.inc
+++ b/meta-security/recipes-ids/samhain/samhain.inc
@@ -40,14 +40,6 @@ SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE:${PN} = "${INITSCRIPT_NAME}.service"
SYSTEMD_AUTO_ENABLE = "disable"
-# mode mapping:
-# BPN MODE_NAME SAMHAIN_MODE
-# samhain-standalone standalone no
-# samhain-client client client
-# samhain-server server server
-MODE_NAME = "${@d.getVar('BPN').split('-')[1]}"
-SAMHAIN_MODE = "${@oe.utils.ifelse(d.getVar('MODE_NAME') == 'standalone', 'no', '${MODE_NAME}')}"
-
# supports mysql|postgresql|oracle|odbc but postgresql is the only one available
PACKAGECONFIG ??= "postgresql ps \
diff --git a/meta-security/recipes-kernel/linux/linux-yocto_5.%.bbappend b/meta-security/recipes-kernel/linux/linux-yocto_6.%.bbappend
index 1d9054faaa..1d9054faaa 100644
--- a/meta-security/recipes-kernel/linux/linux-yocto_5.%.bbappend
+++ b/meta-security/recipes-kernel/linux/linux-yocto_6.%.bbappend