summaryrefslogtreecommitdiff
path: root/meta-tyan/meta-common/recipes-phosphor
diff options
context:
space:
mode:
authorOskar Senft <osk@google.com>2021-12-01 00:05:59 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-12-21 22:52:49 +0300
commit4091a0d42e312c8c9ec9af6525f1074103b97639 (patch)
tree6815c1c8ae503dede3bd70210f67b102009ecc39 /meta-tyan/meta-common/recipes-phosphor
parenta6b6c4abdf1b67e34701d2a9e36123f7f8b4d9a6 (diff)
downloadopenbmc-4091a0d42e312c8c9ec9af6525f1074103b97639.tar.xz
tyan, s7106: Initial commit for TYAN S7106
The TYAN S7106 is a server mainboard with an Aspeed AST2500 BMC. Signed-off-by: Oskar Senft <osk@google.com> Change-Id: I75e4938bbc7d25bd8e949a4bae5761205aa0ff22
Diffstat (limited to 'meta-tyan/meta-common/recipes-phosphor')
-rw-r--r--meta-tyan/meta-common/recipes-phosphor/console/obmc-console/obmc-console.conf3
-rw-r--r--meta-tyan/meta-common/recipes-phosphor/console/obmc-console_%.bbappend2
-rw-r--r--meta-tyan/meta-common/recipes-phosphor/dummy/tyan-dummy.bb8
-rw-r--r--meta-tyan/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend1
-rw-r--r--meta-tyan/meta-common/recipes-phosphor/packagegroups/packagegroup-tyan-apps.bb39
5 files changed, 53 insertions, 0 deletions
diff --git a/meta-tyan/meta-common/recipes-phosphor/console/obmc-console/obmc-console.conf b/meta-tyan/meta-common/recipes-phosphor/console/obmc-console/obmc-console.conf
new file mode 100644
index 0000000000..8491f53653
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-phosphor/console/obmc-console/obmc-console.conf
@@ -0,0 +1,3 @@
+baud = 115200
+local-tty = ttyS3
+local-tty-baud = 115200
diff --git a/meta-tyan/meta-common/recipes-phosphor/console/obmc-console_%.bbappend b/meta-tyan/meta-common/recipes-phosphor/console/obmc-console_%.bbappend
new file mode 100644
index 0000000000..18bcfe350e
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-phosphor/console/obmc-console_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+OBMC_CONSOLE_HOST_TTY = "ttyS2"
diff --git a/meta-tyan/meta-common/recipes-phosphor/dummy/tyan-dummy.bb b/meta-tyan/meta-common/recipes-phosphor/dummy/tyan-dummy.bb
new file mode 100644
index 0000000000..54b93855af
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-phosphor/dummy/tyan-dummy.bb
@@ -0,0 +1,8 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+ALLOW_EMPTY_${PN} = "1"
+
+PROVIDES += "virtual/obmc-fan-mgmt"
+RPROVIDES:${PN} += "virtual-obmc-fan-mgmt"
+
diff --git a/meta-tyan/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend b/meta-tyan/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
new file mode 100644
index 0000000000..bc70432fdf
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG:append = " dynamic-sensors"
diff --git a/meta-tyan/meta-common/recipes-phosphor/packagegroups/packagegroup-tyan-apps.bb b/meta-tyan/meta-common/recipes-phosphor/packagegroups/packagegroup-tyan-apps.bb
new file mode 100644
index 0000000000..b29cca4349
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-phosphor/packagegroups/packagegroup-tyan-apps.bb
@@ -0,0 +1,39 @@
+SUMMARY = "OpenBMC for TYAN - Applications"
+PR = "r1"
+
+inherit packagegroup
+
+PROVIDES = "${PACKAGES}"
+PACKAGES = " \
+ ${PN}-chassis \
+ ${PN}-flash \
+ ${PN}-system \
+ "
+
+PROVIDES += "virtual/obmc-chassis-mgmt"
+PROVIDES += "virtual/obmc-flash-mgmt"
+PROVIDES += "virtual/obmc-system-mgmt"
+
+RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES:${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES:${PN}-system += "virtual-obmc-system-mgmt"
+
+SUMMARY:${PN}-chassis = "TYAN Chassis"
+RDEPENDS:${PN}-chassis = " \
+ x86-power-control \
+ "
+
+SUMMARY:${PN}-flash = "TYAN Flash"
+RDEPENDS:${PN}-flash = " \
+ phosphor-software-manager \
+ "
+
+SUMMARY:${PN}-system = "TYAN System"
+RDEPENDS:${PN}-system = " \
+ dbus-sensors \
+ phosphor-hostlogger \
+ phosphor-sel-logger \
+ ipmitool \
+ phosphor-post-code-manager \
+ phosphor-host-postd \
+ "