summaryrefslogtreecommitdiff
path: root/meta-ufispace/conf
diff options
context:
space:
mode:
authorJordan Chang <jordan.chang@ufispace.com>2023-03-03 10:53:28 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-04-11 21:49:12 +0300
commit7cbff67c14e1d33d2d77dd4b7adcf42426d64a1e (patch)
tree716ca2ea9226f9b9d13dfca97769740213767686 /meta-ufispace/conf
parent8fe218a0ec92f3a788ecd5e68eb84e02a2ec7d75 (diff)
downloadopenbmc-7cbff67c14e1d33d2d77dd4b7adcf42426d64a1e.tar.xz
meta-ufispace: Add meta-ufispace layer and meta-ncplite machine
Iniitial submission of meta-layer and meta-machine layer. Tested: Build and run on our machine successfully. Change-Id: I4920d8ce6aff119ba5cbc4772d84a6377784f85d Signed-off-by: Jordan Chang <jordan.chang@ufispace.com>
Diffstat (limited to 'meta-ufispace/conf')
-rw-r--r--meta-ufispace/conf/layer.conf10
-rw-r--r--meta-ufispace/conf/machine/include/ufispace.inc19
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-ufispace/conf/layer.conf b/meta-ufispace/conf/layer.conf
new file mode 100644
index 0000000000..823a2b0087
--- /dev/null
+++ b/meta-ufispace/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
+ ${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "ufispace-layer"
+BBFILE_PATTERN_ufispace-layer := "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_ufispace-layer = "langdale mickledore"
diff --git a/meta-ufispace/conf/machine/include/ufispace.inc b/meta-ufispace/conf/machine/include/ufispace.inc
new file mode 100644
index 0000000000..d0753f49bc
--- /dev/null
+++ b/meta-ufispace/conf/machine/include/ufispace.inc
@@ -0,0 +1,19 @@
+MACHINE_FEATURES += "\
+ obmc-bmc-state-mgmt \
+ obmc-host-state-mgmt \
+ obmc-chassis-state-mgmt \
+ obmc-host-ipmi \
+ obmc-phosphor-chassis-mgmt \
+ obmc-phosphor-fan-mgmt \
+ obmc-phosphor-flash-mgmt \
+ "
+
+PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-ufispace-apps"
+PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-ufispace-apps"
+PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-ufispace-apps"
+PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-ufispace-apps"
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-kcs"
+
+OVERRIDES .= ":ufispace"
+
+IMAGE_FEATURES:remove = "obmc-ikvm"