summaryrefslogtreecommitdiff
path: root/meta-wistron/meta-lannister/conf
diff options
context:
space:
mode:
authorBob King <Bob_King@wistron.com>2021-12-17 06:35:46 +0300
committerBob King <Bob_King@wistron.com>2022-03-15 05:20:19 +0300
commitf92bdfa9bf6ce5cdfd756c731f4b77e7099473e3 (patch)
treeb9f33265639dddfcaa64e868c2b57cbcfbd2b805 /meta-wistron/meta-lannister/conf
parent2851f39e4b5f51b757c7bfd355d6e751cda78525 (diff)
downloadopenbmc-f92bdfa9bf6ce5cdfd756c731f4b77e7099473e3.tar.xz
meta-wistron: Initial commit for meta-lannister
Add initial commit for Lannister platform. Lannister is an x86 server platform with an ast2600 BMC. Update OWNER list. Tested: 1.Build Lannister image successfully. 2.The image can boot on Lannister platform. Signed-off-by: Bob King <Bob_King@wistron.com> Change-Id: Ibf2b8a30b56722f2fd555d356d76d199e7a9dae5
Diffstat (limited to 'meta-wistron/meta-lannister/conf')
-rw-r--r--meta-wistron/meta-lannister/conf/bblayers.conf.sample19
-rw-r--r--meta-wistron/meta-lannister/conf/conf-notes.txt2
-rw-r--r--meta-wistron/meta-lannister/conf/layer.conf10
-rw-r--r--meta-wistron/meta-lannister/conf/local.conf.sample18
-rw-r--r--meta-wistron/meta-lannister/conf/machine/lannister.conf22
5 files changed, 71 insertions, 0 deletions
diff --git a/meta-wistron/meta-lannister/conf/bblayers.conf.sample b/meta-wistron/meta-lannister/conf/bblayers.conf.sample
new file mode 100644
index 0000000000..0dc4192edf
--- /dev/null
+++ b/meta-wistron/meta-lannister/conf/bblayers.conf.sample
@@ -0,0 +1,19 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "8"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+
+BBLAYERS ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-poky \
+ ##OEROOT##/meta-openembedded/meta-oe \
+ ##OEROOT##/meta-openembedded/meta-networking \
+ ##OEROOT##/meta-openembedded/meta-perl \
+ ##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-aspeed \
+ ##OEROOT##/meta-phosphor \
+ ##OEROOT##/meta-wistron \
+ ##OEROOT##/meta-wistron/meta-lannister \
+ "
diff --git a/meta-wistron/meta-lannister/conf/conf-notes.txt b/meta-wistron/meta-lannister/conf/conf-notes.txt
new file mode 100644
index 0000000000..43d4ab099d
--- /dev/null
+++ b/meta-wistron/meta-lannister/conf/conf-notes.txt
@@ -0,0 +1,2 @@
+Common targets are:
+ obmc-phosphor-image
diff --git a/meta-wistron/meta-lannister/conf/layer.conf b/meta-wistron/meta-lannister/conf/layer.conf
new file mode 100644
index 0000000000..005b99564f
--- /dev/null
+++ b/meta-wistron/meta-lannister/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "lannister"
+BBFILE_PATTERN_lannister = "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_lannister = "honister kirkstone"
diff --git a/meta-wistron/meta-lannister/conf/local.conf.sample b/meta-wistron/meta-lannister/conf/local.conf.sample
new file mode 100644
index 0000000000..7a25c39a37
--- /dev/null
+++ b/meta-wistron/meta-lannister/conf/local.conf.sample
@@ -0,0 +1,18 @@
+MACHINE ??= "lannister"
+DISTRO ?= "openbmc-phosphor"
+PACKAGE_CLASSES ?= "package_ipk"
+SANITY_TESTED_DISTROS:append ?= " *"
+EXTRA_IMAGE_FEATURES += "debug-tweaks"
+USER_CLASSES ?= "buildstats"
+PATCHRESOLVE = "noop"
+BB_DISKMON_DIRS = "\
+ STOPTASKS,${TMPDIR},1G,100K \
+ STOPTASKS,${DL_DIR},1G,100K \
+ STOPTASKS,${SSTATE_DIR},1G,100K \
+ STOPTASKS,/tmp,100M,100K \
+ ABORT,${TMPDIR},100M,1K \
+ ABORT,${DL_DIR},100M,1K \
+ ABORT,${SSTATE_DIR},100M,1K \
+ ABORT,/tmp,10M,1K"
+CONF_VERSION = "2"
+
diff --git a/meta-wistron/meta-lannister/conf/machine/lannister.conf b/meta-wistron/meta-lannister/conf/machine/lannister.conf
new file mode 100644
index 0000000000..5377db02b1
--- /dev/null
+++ b/meta-wistron/meta-lannister/conf/machine/lannister.conf
@@ -0,0 +1,22 @@
+KMACHINE = "aspeed"
+KERNEL_DEVICETREE = "${KMACHINE}-bmc-wistron-${MACHINE}.dtb"
+
+require conf/machine/include/wistron.inc
+require conf/machine/include/ast2600.inc
+require conf/machine/include/obmc-bsp-common.inc
+
+UBOOT_MACHINE = "ast2600_openbmc_defconfig"
+UBOOT_DEVICETREE = "ast2600-intel"
+SPL_BINARY = "spl/u-boot-spl.bin"
+SOCSEC_SIGN_ENABLE = "0"
+
+SERIAL_CONSOLES = "115200;ttyS4"
+
+FLASH_SIZE = "65536"
+
+OBMC_MACHINE_FEATURES += "\
+ obmc-chassis-state-mgmt \
+ obmc-host-state-mgmt \
+ "
+VIRTUAL-RUNTIME_obmc-host-state-manager ?= "x86-power-control"
+VIRTUAL-RUNTIME_obmc-chassis-state-manager ?= "x86-power-control"