summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-14 20:05:37 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 04:26:31 +0300
commiteb8dc40360f0cfef56fb6947cc817a547d6d9bc6 (patch)
treede291a73dc37168da6370e2cf16c347d1eba9df8 /poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
parent9c3cf826d853102535ead04cebc2d6023eff3032 (diff)
downloadopenbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.tar.xz
[Subtree] Removing import-layers directory
As part of the move to subtrees, need to bring all the import layers content to the top level. Change-Id: I4a163d10898cbc6e11c27f776f60e1a470049d8f Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb')
-rw-r--r--poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb b/poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
new file mode 100644
index 0000000000..001db9e5e2
--- /dev/null
+++ b/poky/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2011 Intel Corporation
+#
+
+PR = "r40"
+
+inherit packagegroup distro_features_check
+REQUIRED_DISTRO_FEATURES = "x11"
+
+PACKAGES = "${PN} ${PN}-utils"
+
+# backwards compatibility for xserver-common
+VIRTUAL-RUNTIME_xserver_common ?= ""
+
+# elsa, xserver-nodm-init
+VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
+
+SUMMARY = "X11 display server and basic utilities"
+RDEPENDS_${PN} = "\
+ ${PN}-xserver \
+ ${PN}-utils \
+ "
+
+SUMMARY_${PN}-utils = "X11 basic utilities and init"
+RDEPENDS_${PN}-utils = "\
+ ${VIRTUAL-RUNTIME_xserver_common} \
+ ${VIRTUAL-RUNTIME_graphical_init_manager} \
+ xauth \
+ xhost \
+ xset \
+ xrandr \
+ xmodmap \
+ xdpyinfo \
+ xinput-calibrator \
+ dbus-x11 \
+ "