summaryrefslogtreecommitdiff
path: root/import-layers/meta-openembedded/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-openembedded/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb')
-rw-r--r--import-layers/meta-openembedded/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb31
1 files changed, 24 insertions, 7 deletions
diff --git a/import-layers/meta-openembedded/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb b/import-layers/meta-openembedded/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
index 5052b36fc3..34fc97d4ac 100644
--- a/import-layers/meta-openembedded/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
+++ b/import-layers/meta-openembedded/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
@@ -3,11 +3,26 @@ HOMEPAGE = "http://www.abiword.org"
SECTION = "x11/office"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
-DEPENDS = "perl-native wv libglade libfribidi jpeg libpng \
- librsvg libwmf-native gtkmathview asio gtk+ evolution-data-server \
- ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'redland rasqal', '', d)}"
-RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
- glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+DEPENDS = " \
+ perl-native \
+ gtk+ \
+ gtkmathview \
+ wv \
+ libglade \
+ libfribidi \
+ jpeg \
+ libpng \
+ librsvg \
+ libwmf-native \
+ asio \
+ evolution-data-server \
+ libxslt \
+ ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'redland rasqal', '', d)} \
+"
+RDEPENDS_${PN}_append_libc-glibc = " \
+ glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1 \
+"
RCONFLICTS_${PN} = "${PN}-embedded"
SRC_URI = " \
@@ -22,7 +37,7 @@ SRC_URI[md5sum] = "f3f8052e7b4979a43b75775a381e6cb8"
SRC_URI[sha256sum] = "e094f6fbf0afc5c5538b4894888e7c346f8ee8f49c9d24821dd696d0734865c6"
#want 3.x from 3.x.y for the installation directory
-SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
+SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
inherit autotools-brokensep pkgconfig
@@ -47,6 +62,8 @@ EXTRA_OECONF = " --disable-static \
--with-libwmf-config=${STAGING_DIR} \
"
+LDFLAGS += "-lgmodule-2.0"
+
do_compile() {
cd goffice-bits2
make goffice-paths.h
@@ -111,7 +128,7 @@ python populate_packages_prepend () {
d.setVar('FILES_' + metapkg, "")
blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
metapkg_rdepends = []
- packages = d.getVar('PACKAGES', 1).split()
+ packages = d.getVar('PACKAGES').split()
for pkg in packages[1:]:
if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
print("Modifying %s" % pkg)