summaryrefslogtreecommitdiff
path: root/meta-asrock/meta-x570d4u/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-asrock/meta-x570d4u/conf')
-rw-r--r--meta-asrock/meta-x570d4u/conf/layer.conf10
-rw-r--r--meta-asrock/meta-x570d4u/conf/machine/x570d4u.conf21
-rw-r--r--meta-asrock/meta-x570d4u/conf/templates/default/bblayers.conf.sample17
-rw-r--r--meta-asrock/meta-x570d4u/conf/templates/default/conf-notes.txt3
-rw-r--r--meta-asrock/meta-x570d4u/conf/templates/default/local.conf.sample17
5 files changed, 68 insertions, 0 deletions
diff --git a/meta-asrock/meta-x570d4u/conf/layer.conf b/meta-asrock/meta-x570d4u/conf/layer.conf
new file mode 100644
index 0000000000..484b6a34f4
--- /dev/null
+++ b/meta-asrock/meta-x570d4u/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "x570d4u-layer"
+BBFILE_PATTERN_x570d4u-layer := "^${LAYERDIR}/"
+LAYERSERIES_COMPAT_x570d4u-layer = "nanbield scarthgap"
diff --git a/meta-asrock/meta-x570d4u/conf/machine/x570d4u.conf b/meta-asrock/meta-x570d4u/conf/machine/x570d4u.conf
new file mode 100644
index 0000000000..8ff4d77661
--- /dev/null
+++ b/meta-asrock/meta-x570d4u/conf/machine/x570d4u.conf
@@ -0,0 +1,21 @@
+KMACHINE = "aspeed"
+KERNEL_DEVICETREE = "aspeed/${KMACHINE}-bmc-asrock-${MACHINE}.dtb"
+
+UBOOT_DEVICETREE = "ast2500-evb"
+UBOOT_MACHINE = "evb-ast2500_defconfig"
+
+FLASH_SIZE = "65536"
+
+require conf/machine/include/ast2500.inc
+require conf/machine/include/obmc-bsp-common.inc
+
+PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-asrock-apps"
+PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-asrock-apps"
+PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-asrock-apps"
+PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-asrock-apps"
+
+VIRTUAL-RUNTIME_obmc-inventory-manager = "entity-manager"
+VIRTUAL-RUNTIME_obmc-sensors-hwmon = "dbus-sensors"
+
+VIRTUAL-RUNTIME_obmc-host-state-manager = "x86-power-control"
+VIRTUAL-RUNTIME_obmc-chassis-state-manager = "x86-power-control"
diff --git a/meta-asrock/meta-x570d4u/conf/templates/default/bblayers.conf.sample b/meta-asrock/meta-x570d4u/conf/templates/default/bblayers.conf.sample
new file mode 100644
index 0000000000..c533858a27
--- /dev/null
+++ b/meta-asrock/meta-x570d4u/conf/templates/default/bblayers.conf.sample
@@ -0,0 +1,17 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "8"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+
+BBLAYERS ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-openembedded/meta-oe \
+ ##OEROOT##/meta-openembedded/meta-networking \
+ ##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-phosphor \
+ ##OEROOT##/meta-aspeed \
+ ##OEROOT##/meta-asrock \
+ ##OEROOT##/meta-asrock/meta-x570d4u \
+ "
diff --git a/meta-asrock/meta-x570d4u/conf/templates/default/conf-notes.txt b/meta-asrock/meta-x570d4u/conf/templates/default/conf-notes.txt
new file mode 100644
index 0000000000..48199923b8
--- /dev/null
+++ b/meta-asrock/meta-x570d4u/conf/templates/default/conf-notes.txt
@@ -0,0 +1,3 @@
+Example build invocations:
+
+bitbake obmc-phosphor-image
diff --git a/meta-asrock/meta-x570d4u/conf/templates/default/local.conf.sample b/meta-asrock/meta-x570d4u/conf/templates/default/local.conf.sample
new file mode 100644
index 0000000000..6829912585
--- /dev/null
+++ b/meta-asrock/meta-x570d4u/conf/templates/default/local.conf.sample
@@ -0,0 +1,17 @@
+MACHINE ??= "x570d4u"
+DISTRO ?= "openbmc-phosphor"
+PACKAGE_CLASSES ?= "package_ipk"
+SANITY_TESTED_DISTROS:append ?= " *"
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+USER_CLASSES ?= "buildstats"
+PATCHRESOLVE = "noop"
+BB_DISKMON_DIRS = "\
+ STOPTASKS,${TMPDIR},1G,100K \
+ STOPTASKS,${DL_DIR},1G,100K \
+ STOPTASKS,${SSTATE_DIR},1G,100K \
+ STOPTASKS,/tmp,100M,100K \
+ HALT,${TMPDIR},100M,1K \
+ HALT,${DL_DIR},100M,1K \
+ HALT,${SSTATE_DIR},100M,1K \
+ HALT,/tmp,10M,1K"
+CONF_VERSION = "2"