summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/storage/emmc-service.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google/recipes-google/storage/emmc-service.bb')
-rw-r--r--meta-google/recipes-google/storage/emmc-service.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-google/recipes-google/storage/emmc-service.bb b/meta-google/recipes-google/storage/emmc-service.bb
new file mode 100644
index 0000000000..c95867cedb
--- /dev/null
+++ b/meta-google/recipes-google/storage/emmc-service.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Storage management daemon for eMMC"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+RDEPENDS:${PN} += "estoraged"
+
+SRC_URI += " file://emmc.service"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} += "emmc.service"
+
+do_install:append() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/emmc.service ${D}${systemd_system_unitdir}
+}