summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/OWNERS1
-rw-r--r--meta-google/classes/image_types_hoth.bbclass5
-rw-r--r--meta-google/conf/distro/gbmc.conf7
-rw-r--r--meta-google/recipes-google/google-misc/google-misc.inc2
-rw-r--r--meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb2
-rw-r--r--meta-google/recipes-google/nanopb/nanopb-generator_0.4.8.bb14
-rw-r--r--meta-google/recipes-google/nanopb/nanopb-runtime_0.4.8.bb17
-rw-r--r--meta-google/recipes-google/nanopb/nanopb.bb17
-rw-r--r--meta-google/recipes-google/nanopb/nanopb.inc13
-rw-r--r--meta-google/recipes-google/ncsi/ncsid_git.bb6
10 files changed, 13 insertions, 71 deletions
diff --git a/meta-google/OWNERS b/meta-google/OWNERS
index 1972513e66..be13eef2c6 100644
--- a/meta-google/OWNERS
+++ b/meta-google/OWNERS
@@ -2,7 +2,6 @@ owners:
- yuenn@google.com
- wak@google.com
- benjaminfair@google.com
-- edtanous@google.com
- brandonkim@google.com
- wltu@google.com
- nanzhoumails@gmail.com
diff --git a/meta-google/classes/image_types_hoth.bbclass b/meta-google/classes/image_types_hoth.bbclass
index f01ed90ddc..00e9c4c1ff 100644
--- a/meta-google/classes/image_types_hoth.bbclass
+++ b/meta-google/classes/image_types_hoth.bbclass
@@ -9,9 +9,14 @@ FLASH_HOTH_SECONDARY_OFFSET:hoth = "${@61376 if FLASH_SIZE == '65536' else 7296}
FLASH_IMAGE_DESC_OFFSET:hoth:aarch64 = "${@61312 if FLASH_SIZE == '65536' else 7232}"
FLASH_HOTH_UPDATE_OFFSET:hoth:aarch64 = "${@61376 if FLASH_SIZE == '65536' else 31744}"
+FLASH_IMAGE_DESC_OFFSET:hoth:aarch64:flash-131072 = "126848"
+FLASH_HOTH_UPDATE_OFFSET:hoth:aarch64:flash-131072 = "126912"
+FLASH_HOTH_MAILBOX_OFFSET:hoth:aarch64:flash-131072 = "131008"
+
# Leave a zero-size u-boot env partition.
FLASH_UBOOT_ENV_OFFSET = "${FLASH_KERNEL_OFFSET}"
FLASH_UBOOT_ENV_OFFSET:flash-65536 = "${FLASH_KERNEL_OFFSET:flash-65536}"
+FLASH_UBOOT_ENV_OFFSET:flash-131072 = "${FLASH_KERNEL_OFFSET:flash-131072}"
# Support BMC image to have secondary hoth firmware
ENABLE_HOTH_SECONDARY ?= "no"
diff --git a/meta-google/conf/distro/gbmc.conf b/meta-google/conf/distro/gbmc.conf
index 1311aa7529..0f5c6e8672 100644
--- a/meta-google/conf/distro/gbmc.conf
+++ b/meta-google/conf/distro/gbmc.conf
@@ -39,10 +39,15 @@ OBMC_ORG_YAML_SUBDIRS += " com/google"
# Force the patches to not have any fuzz for gBMC
ERROR_QA:append = " patch-fuzz"
-IGPS_MACHINE:npcm8xx = "Google"
+IGPS_MACHINE_DEFAULT = "EB"
+IGPS_MACHINE_DEFAULT:npcm8xx = "Google"
+IGPS_MACHINE ?= "${IGPS_MACHINE_DEFAULT}"
# Remove dependencies on python3-core when using nftables
PACKAGECONFIG:remove:pn-nftables = "python"
# Do not configure TPM layer
SKIP_META_TPM_SANITY_CHECK = "1"
+
+# Set /var/log directory to be volatile
+VOLATILE_LOG_DIR = "yes"
diff --git a/meta-google/recipes-google/google-misc/google-misc.inc b/meta-google/recipes-google/google-misc/google-misc.inc
index 477009357d..9870e97723 100644
--- a/meta-google/recipes-google/google-misc/google-misc.inc
+++ b/meta-google/recipes-google/google-misc/google-misc.inc
@@ -6,7 +6,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://../../LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
SRC_URI += "git://github.com/openbmc/google-misc;branch=master;protocol=https"
-SRCREV = "4dba220d361271859f824aaa2c7861ceb63ca2dd"
+SRCREV = "08988f3dd9b4e0eed788f029d380c876841c09eb"
S = "${WORKDIR}/git/subprojects/${GOOGLE_MISC_PROJ}"
inherit meson pkgconfig
diff --git a/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb b/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
index 850d9b4715..383d9ad978 100644
--- a/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
+++ b/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
@@ -23,7 +23,7 @@ RDEPENDS:${PN} += " \
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/google-ipmi-sys;branch=master;protocol=https"
-SRCREV = "9846023c7e811d6f831941d37270b10046916fef"
+SRCREV = "56b2d9f30b05a0471fec58adbba666bfe31032f3"
FILES:${PN} += "${libdir}/ipmid-providers"
diff --git a/meta-google/recipes-google/nanopb/nanopb-generator_0.4.8.bb b/meta-google/recipes-google/nanopb/nanopb-generator_0.4.8.bb
deleted file mode 100644
index c86750f8b6..0000000000
--- a/meta-google/recipes-google/nanopb/nanopb-generator_0.4.8.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-require nanopb.inc
-
-inherit python3-dir
-
-DEPENDS = "protobuf-native"
-RDEPENDS:${PN} += "python3-protobuf"
-
-EXTRA_OECMAKE += " \
- -Dnanopb_PYTHON_INSTDIR_OVERRIDE=${PYTHON_SITEPACKAGES_DIR} \
- -Dnanopb_BUILD_RUNTIME=OFF \
- -Dnanopb_BUILD_GENERATOR=ON \
- "
-
-FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
diff --git a/meta-google/recipes-google/nanopb/nanopb-runtime_0.4.8.bb b/meta-google/recipes-google/nanopb/nanopb-runtime_0.4.8.bb
deleted file mode 100644
index e43931a4ec..0000000000
--- a/meta-google/recipes-google/nanopb/nanopb-runtime_0.4.8.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-require nanopb.inc
-
-EXTRA_OECMAKE += " \
- -Dnanopb_PROTOC_PATH=/bin/false \
- -DBUILD_SHARED_LIBS=ON \
- -Dnanopb_BUILD_RUNTIME=ON \
- -Dnanopb_BUILD_GENERATOR=OFF \
- "
-
-# Maintain compatability with old header locations for packages
-# which haven't yet migrated to `nanopb/pb*.h`
-do_install:append() {
- for hdr in ${D}${includedir}/nanopb/*; do
- ln -sv nanopb/$(basename "$hdr") ${D}${includedir}/
- done
-}
-
diff --git a/meta-google/recipes-google/nanopb/nanopb.bb b/meta-google/recipes-google/nanopb/nanopb.bb
deleted file mode 100644
index 7ad6a32782..0000000000
--- a/meta-google/recipes-google/nanopb/nanopb.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Combined nanopb package"
-PV = "1.0"
-PR = "r1"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-inherit packagegroup
-
-DEPENDS = " \
- nanopb-generator \
- nanopb-runtime \
-"
-
-RDEPENDS:${PN} = " \
- nanopb-generator \
- nanopb-runtime \
-"
diff --git a/meta-google/recipes-google/nanopb/nanopb.inc b/meta-google/recipes-google/nanopb/nanopb.inc
deleted file mode 100644
index 87dbc73e63..0000000000
--- a/meta-google/recipes-google/nanopb/nanopb.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION="Protocol Buffers with small code size"
-LICENSE="Zlib"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9db4b73a55a3994384112efcdb37c01f"
-
-SRC_URI = "git://github.com/nanopb/nanopb.git;branch=master;protocol=https"
-SRCREV = "6cfe48d6f1593f8fa5c0f90437f5e6522587745e"
-
-S = "${WORKDIR}/git"
-
-inherit cmake
-
-BBCLASSEXTEND = "native nativesdk"
-
diff --git a/meta-google/recipes-google/ncsi/ncsid_git.bb b/meta-google/recipes-google/ncsi/ncsid_git.bb
index 12a8d03407..6fad50a3ca 100644
--- a/meta-google/recipes-google/ncsi/ncsid_git.bb
+++ b/meta-google/recipes-google/ncsi/ncsid_git.bb
@@ -11,16 +11,10 @@ EXTRA_OEMESON = " \
"
SYSTEMD_SERVICE:${PN} += " \
- dhcp4@.service \
- dhcp6@.service \
ncsid@.service \
nic-hostful@.target \
nic-hostless@.target \
update-ra-gw@.service \
- update-ra-neighbor@.service \
- update-ra-neighbor@.timer \
- update-static-neighbors@.service \
- update-static-neighbors@.timer \
"
DEPENDS += " \