summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/networking/dhcp-done/50-dhcp-done.rules5
-rw-r--r--meta-google/recipes-google/networking/dhcp-done_git.bb22
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-google/recipes-google/networking/dhcp-done/50-dhcp-done.rules b/meta-google/recipes-google/networking/dhcp-done/50-dhcp-done.rules
new file mode 100644
index 0000000000..f84b6c0561
--- /dev/null
+++ b/meta-google/recipes-google/networking/dhcp-done/50-dhcp-done.rules
@@ -0,0 +1,5 @@
+table inet filter {
+ chain gbmc_br_pub_input {
+ tcp dport 23 accept
+ }
+}
diff --git a/meta-google/recipes-google/networking/dhcp-done_git.bb b/meta-google/recipes-google/networking/dhcp-done_git.bb
new file mode 100644
index 0000000000..5732033153
--- /dev/null
+++ b/meta-google/recipes-google/networking/dhcp-done_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Google DHCP completion daemon"
+DESCRIPTION = "Google DHCP completion daemon"
+GOOGLE_MISC_PROJ = "dhcp-done"
+
+require ../google-misc/google-misc.inc
+
+inherit systemd
+
+SYSTEMD_SERVICE:${PN} += "dhcp-done.service"
+
+DEPENDS += " \
+ sdeventplus \
+ stdplus \
+ "
+
+SRC_URI += "file://50-dhcp-done.rules"
+FILES:${PN} += "${sysconfdir}/nftables"
+do_install:append() {
+ nftables_dir=${D}${sysconfdir}/nftables
+ install -d -m0755 "$nftables_dir"
+ install -m0644 ${WORKDIR}/50-dhcp-done.rules $nftables_dir/
+}