summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-sbp1/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/meta-sbp1/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend')
-rw-r--r--meta-ibm/meta-sbp1/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-ibm/meta-sbp1/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-ibm/meta-sbp1/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
new file mode 100644
index 0000000000..400f9df09c
--- /dev/null
+++ b/meta-ibm/meta-sbp1/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -0,0 +1,19 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+inherit systemd
+inherit obmc-phosphor-systemd
+
+SRC_URI += " \
+ file://phosphor-multi-gpio-presence.json \
+ file://dependencies.conf \
+ "
+
+FILES:${PN}-presence += " ${datadir}/${PN}/phosphor-multi-gpio-presence.json \
+ ${systemd_system_unitdir}/phosphor-multi-gpio-presence.service.d/dependencies.conf \
+ "
+
+do_install:append() {
+ rm -f ${D}${datadir}/${PN}/phosphor-multi-gpio-presence.json
+ install -m 0644 ${WORKDIR}/phosphor-multi-gpio-presence.json ${D}${datadir}/${PN}/
+ install -d ${D}${systemd_system_unitdir}/phosphor-multi-gpio-presence.service.d/
+ install -m 644 -D ${WORKDIR}/dependencies.conf ${D}${systemd_system_unitdir}/phosphor-multi-gpio-presence.service.d/dependencies.conf
+}