summaryrefslogtreecommitdiff
path: root/meta-openbmc-machines/meta-openpower/common/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-phosphor')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/inventory-upload/inventory-upload.bb5
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/inventory-upload/inventory-upload/inventory-upload.service10
2 files changed, 14 insertions, 1 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/inventory-upload/inventory-upload.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/inventory-upload/inventory-upload.bb
index 8c0bd34e32..c3a23610ce 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/inventory-upload/inventory-upload.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/inventory-upload/inventory-upload.bb
@@ -6,15 +6,18 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit allarch
+inherit obmc-phosphor-systemd
inherit setuptools
RDEPENDS_${PN} += " \
+ python-dbus \
+ python-pygobject \
pyphosphor \
dtc \
"
SRC_URI += "git://github.com/openbmc/openpower-inventory-upload"
-SRCREV = "5909e7859a1a56bdc902cf774093d9fae29612ea"
+SRCREV = "867e058dd246739ab9c93df64e82b7526f42d67f"
S = "${WORKDIR}/git"
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/inventory-upload/inventory-upload/inventory-upload.service b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/inventory-upload/inventory-upload/inventory-upload.service
new file mode 100644
index 0000000000..18d1f4bb8d
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/inventory-upload/inventory-upload/inventory-upload.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=BMC Inventory Upload
+Requires=skeleton.service
+After=skeleton.service
+
+[Service]
+ExecStart=/usr/sbin/inventory_upload.py
+
+[Install]
+WantedBy=multi-user.target