summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-support/mctp/mctp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-support/mctp/mctp_git.bb')
-rw-r--r--meta-openembedded/meta-networking/recipes-support/mctp/mctp_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-openembedded/meta-networking/recipes-support/mctp/mctp_git.bb b/meta-openembedded/meta-networking/recipes-support/mctp/mctp_git.bb
index 516f3e2d9e..9e97a6a60a 100644
--- a/meta-openembedded/meta-networking/recipes-support/mctp/mctp_git.bb
+++ b/meta-openembedded/meta-networking/recipes-support/mctp/mctp_git.bb
@@ -22,13 +22,16 @@ PACKAGECONFIG ??= " \
# mctpd will only be built if pkg-config detects libsystemd; in which case
# we'll want to declare the dep and install the service.
PACKAGECONFIG[systemd] = ",,systemd,libsystemd"
-SYSTEMD_SERVICE:${PN} = "mctpd.service"
+SYSTEMD_SERVICE:${PN} = "mctpd.service mctp.target mctp-local.target"
+SYSTEMD_AUTO_ENABLE_${PN} = "enable"
do_install:append () {
if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${S}/conf/mctpd.service \
${D}${systemd_system_unitdir}/mctpd.service
+ install -m 0644 ${S}/conf/*.target \
+ ${D}${systemd_system_unitdir}/
install -d ${D}${datadir}/dbus-1/system.d
install -m 0644 ${S}/conf/mctpd-dbus.conf \
${D}${datadir}/dbus-1/system.d/mctpd.conf