summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-support/spice/spice-gtk_0.42.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-support/spice/spice-gtk_0.42.bb')
-rw-r--r--meta-openembedded/meta-networking/recipes-support/spice/spice-gtk_0.42.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/meta-openembedded/meta-networking/recipes-support/spice/spice-gtk_0.42.bb b/meta-openembedded/meta-networking/recipes-support/spice/spice-gtk_0.42.bb
index 27504392a6..3d34f222d0 100644
--- a/meta-openembedded/meta-networking/recipes-support/spice/spice-gtk_0.42.bb
+++ b/meta-openembedded/meta-networking/recipes-support/spice/spice-gtk_0.42.bb
@@ -40,19 +40,23 @@ DEPENDS = " \
"
DEPENDS:append:libc-musl = " libucontext"
-RDEPENDS:${PN} = "python3-pyparsing python3-six"
+RDEPENDS:${PN} = "python3-pyparsing python3-six usbids"
-inherit meson pkgconfig vala gobject-introspection features_check
+inherit meson pkgconfig vala gobject-introspection features_check gtk-doc
REQUIRED_DISTRO_FEATURES = "opengl"
GIR_MESON_ENABLE_FLAG = 'enabled'
GIR_MESON_DISABLE_FLAG = 'disabled'
+GTKDOC_MESON_OPTION = 'gtk_doc'
+GTKDOC_MESON_ENABLE_FLAG = 'enabled'
+GTKDOC_MESON_DISABLE_FLAG = 'disabled'
-PACKAGECONFIG ??= "${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vapi', '', d)}"
+PACKAGECONFIG ??= "${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vapi', '', d)} smartcard"
PACKAGECONFIG[vapi] = "-Dvapi=enabled,-Dvapi=disabled"
+PACKAGECONFIG[smartcard] = "-Dsmartcard=enabled,-Dsmartcard=disabled,libcacard"
-EXTRA_OEMESON = "-Dpie=true"
+EXTRA_OEMESON = "-Dpie=true -Dusb-ids-path=${datadir}/usb.ids "
EXTRA_OEMESON:append:libc-musl = " -Dcoroutine=libucontext"
LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' -Wl,--undefined-version', '', d)}"