summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/geany
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/geany')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/geany/geany-plugins/0001-geany.m4-Do-not-tinker-with-pkg-config-paths.patch32
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/geany/geany-plugins_1.38.bb15
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/geany/geany_1.38.bb2
3 files changed, 41 insertions, 8 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/geany/geany-plugins/0001-geany.m4-Do-not-tinker-with-pkg-config-paths.patch b/meta-openembedded/meta-oe/recipes-devtools/geany/geany-plugins/0001-geany.m4-Do-not-tinker-with-pkg-config-paths.patch
new file mode 100644
index 0000000000..cd417e0d7b
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/geany/geany-plugins/0001-geany.m4-Do-not-tinker-with-pkg-config-paths.patch
@@ -0,0 +1,32 @@
+From b2187b45f61ce362a9d58d9081d66daddb4e577f Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 20 Mar 2022 15:54:14 -0700
+Subject: [PATCH] geany.m4: Do not tinker with pkg-config paths
+
+OE sets up these paths correctly w.r.t. target sysroot
+
+Upstream-Status: Inappropriate [OE-Specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ build/geany.m4 | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/build/geany.m4
++++ b/build/geany.m4
+@@ -32,7 +32,8 @@ AC_DEFUN([GP_CHECK_GEANY],
+ [
+ AC_REQUIRE([PKG_PROG_PKG_CONFIG])
+
+- GP_GEANY_PKG_CONFIG_PATH_PUSH
++ dnl GP_GEANY_PKG_CONFIG_PATH_PUSH
++ AC_REQUIRE([_GP_GEANY_LIBDIR])
+
+ PKG_CHECK_MODULES([GEANY], [geany >= $1])
+ geanypluginsdir=$geany_libdir/geany
+@@ -40,5 +41,5 @@ AC_DEFUN([GP_CHECK_GEANY],
+ AC_SUBST([geanypluginsdir])
+ AC_SUBST([GEANY_VERSION])
+
+- GP_GEANY_PKG_CONFIG_PATH_POP
++ dnl GP_GEANY_PKG_CONFIG_PATH_POP
+ ])
diff --git a/meta-openembedded/meta-oe/recipes-devtools/geany/geany-plugins_1.38.bb b/meta-openembedded/meta-oe/recipes-devtools/geany/geany-plugins_1.38.bb
index bb419c976a..fa4cccca03 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/geany/geany-plugins_1.38.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/geany/geany-plugins_1.38.bb
@@ -1,8 +1,8 @@
DESCRIPTION = "A fast and lightweight IDE"
HOMEPAGE = "http://plugins.geany.org/"
-LICENSE_DEFAULT = "GPLv2"
-LICENSE = "${LICENSE_DEFAULT} & BSD-2-Clause & GPLv3"
+LICENSE_DEFAULT = "GPL-2.0-only"
+LICENSE = "${LICENSE_DEFAULT} & BSD-2-Clause & GPL-3.0-only"
python () {
for plugin in d.getVar('PLUGINS').split():
@@ -32,6 +32,7 @@ SRC_URI = " \
https://plugins.geany.org/${BPN}/${BP}.tar.bz2 \
file://0001-Use-pkg-config-to-find-gpgme.patch \
file://0001-git-changebar-Adjust-structs-for-libgit2-1.4.x.patch \
+ file://0001-geany.m4-Do-not-tinker-with-pkg-config-paths.patch \
"
SRC_URI[sha256sum] = "1c578a7ebb390aa8882f195acd3d8da3ceb73925d291b28dec90cd3e5fd20586"
@@ -60,7 +61,7 @@ FILES:${PN}-codenav = "${libdir}/geany/codenav.so"
PLUGINS += "${PN}-commander"
LIC_FILES_CHKSUM += "file://commander/COPYING;md5=d32239bcb673463ab874e80d47fae504"
-LICENSE:${PN}-commander = "GPLv3"
+LICENSE:${PN}-commander = "GPL-3.0-only"
FILES:${PN}-commander = "${libdir}/geany/commander.so"
# | checking whether the GTK version in use is compatible with plugin Debugger... no
@@ -86,7 +87,7 @@ FILES:${PN}-geanyctags = "${libdir}/geany/geanyctags.so"
PLUGINS += "${PN}-geanydoc"
LIC_FILES_CHKSUM += "file://geanydoc/COPYING;md5=d32239bcb673463ab874e80d47fae504"
-LICENSE:${PN}-geanydoc = "GPLv3"
+LICENSE:${PN}-geanydoc = "GPL-3.0-only"
FILES:${PN}-geanydoc = "${libdir}/geany/geanydoc.so"
PLUGINS += "${PN}-geanyextrasel"
@@ -121,7 +122,7 @@ FILES:${PN}-geanypg = "${libdir}/geany/geanypg.so"
PLUGINS += "${PN}-geanyprj"
LIC_FILES_CHKSUM += "file://geanyprj/COPYING;md5=d32239bcb673463ab874e80d47fae504"
-LICENSE:${PN}-geanyprj = "GPLv3"
+LICENSE:${PN}-geanyprj = "GPL-3.0-only"
FILES:${PN}-geanyprj = "${libdir}/geany/geanyprj.so"
#PLUGINS += "${PN}-geanypy"
@@ -138,7 +139,7 @@ FILES:${PN}-geniuspaste = "${libdir}/geany/geniuspaste.so ${datadir}/${PN}/geniu
PLUGINS += "${PN}-git-changebar"
LIC_FILES_CHKSUM += "file://git-changebar/COPYING;md5=d32239bcb673463ab874e80d47fae504"
-LICENSE:${PN}-git-changebar = "GPLv3"
+LICENSE:${PN}-git-changebar = "GPL-3.0-only"
FILES:${PN}-git-changebar = "${datadir}/${BPN}/git-changebar ${libdir}/geany/git-changebar.so"
PLUGINS += "${PN}-keyrecord"
@@ -179,7 +180,7 @@ LIC_FILES_CHKSUM += "file://pairtaghighlighter/COPYING;md5=d6d927525a612b3a8dbeb
FILES:${PN}-pairtaghighlighter = "${libdir}/geany/pairtaghighlighter.so"
PLUGINS += "${PN}-pohelper"
-LICENSE:${PN}-pohelper = "GPLv3"
+LICENSE:${PN}-pohelper = "GPL-3.0-only"
LIC_FILES_CHKSUM += "file://pohelper/COPYING;md5=d32239bcb673463ab874e80d47fae504"
FILES:${PN}-pohelper = "${datadir}/${BPN}/pohelper ${libdir}/geany/pohelper.so"
diff --git a/meta-openembedded/meta-oe/recipes-devtools/geany/geany_1.38.bb b/meta-openembedded/meta-oe/recipes-devtools/geany/geany_1.38.bb
index 33d0870eb9..d75e3b57fb 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/geany/geany_1.38.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/geany/geany_1.38.bb
@@ -1,6 +1,6 @@
SUMMARY = "A fast and lightweight IDE"
HOMEPAGE = "http://www.geany.org/"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=bd7b2c994af21d318bd2cd3b3f80c2d5"
DEPENDS = "gtk+3 libxml-parser-perl-native python3-docutils-native intltool-native"