summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/php/php_8.2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/php/php_8.2.7.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/php/php_8.2.7.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/php/php_8.2.7.bb b/meta-openembedded/meta-oe/recipes-devtools/php/php_8.2.7.bb
index b5da7b3444..4dc0399b59 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/php/php_8.2.7.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/php/php_8.2.7.bb
@@ -42,7 +42,7 @@ CVE_CHECK_IGNORE += "\
CVE-2007-4596 \
"
-inherit autotools pkgconfig python3native gettext
+inherit autotools pkgconfig python3native gettext multilib_header multilib_script
# phpize is not scanned for absolute paths by default (but php-config is).
#
@@ -210,6 +210,14 @@ do_install:append:class-target() {
fi
}
+MULTILIB_SCRIPTS += "${PN}:${bindir}/php-config \
+ ${PN}:${bindir}/phpize \
+"
+
+do_install:append () {
+ oe_multilib_header php/main/build-defs.h php/main/php_config.h
+}
+
SYSROOT_PREPROCESS_FUNCS += "php_sysroot_preprocess"
php_sysroot_preprocess () {