summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-gnome')
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/gnome-themes/adw-gtk3_4.7.bb (renamed from meta-openembedded/meta-oe/recipes-gnome/gnome-themes/adw-gtk3_4.6.bb)2
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/0001-Remove-builddir-and-srcdir-paths-from-test-binaries.patch82
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.36.0.bb3
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/vte9/vte9.inc2
5 files changed, 88 insertions, 3 deletions
diff --git a/meta-openembedded/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb b/meta-openembedded/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb
index 86a941f4a8..ceebe5ebd3 100644
--- a/meta-openembedded/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb
+++ b/meta-openembedded/meta-oe/recipes-gnome/gnome-common/gnome-common_3.18.0.bb
@@ -16,7 +16,7 @@ DEPENDS = ""
# Default to enable autoconf-archive to avoid conflicts
PACKAGECONFIG ??= "autoconf-archive"
-PACKAGECONFIG[autoconf-archive] = "--with-autoconf-archive, --without-autoconf-archive, autoconf-archive"
+PACKAGECONFIG[autoconf-archive] = "--with-autoconf-archive, --without-autoconf-archive, autoconf-archive,autoconf-archive"
FILES:${PN} += "${datadir}/aclocal"
FILES:${PN}-dev = ""
diff --git a/meta-openembedded/meta-oe/recipes-gnome/gnome-themes/adw-gtk3_4.6.bb b/meta-openembedded/meta-oe/recipes-gnome/gnome-themes/adw-gtk3_4.7.bb
index 0b121183ac..8f412e431a 100644
--- a/meta-openembedded/meta-oe/recipes-gnome/gnome-themes/adw-gtk3_4.6.bb
+++ b/meta-openembedded/meta-oe/recipes-gnome/gnome-themes/adw-gtk3_4.7.bb
@@ -11,6 +11,6 @@ inherit meson
SRC_URI = "git://github.com/lassekongo83/adw-gtk3.git;protocol=https;branch=main"
S = "${WORKDIR}/git"
-SRCREV = "f26e86c8a7b40ac23f165efdb620f734c0f1db23"
+SRCREV = "f5e0807a4572ef6d9ca27042b41211efb41936d2"
FILES:${PN} = "${datadir}/themes"
diff --git a/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/0001-Remove-builddir-and-srcdir-paths-from-test-binaries.patch b/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/0001-Remove-builddir-and-srcdir-paths-from-test-binaries.patch
new file mode 100644
index 0000000000..6bb48777ec
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas/0001-Remove-builddir-and-srcdir-paths-from-test-binaries.patch
@@ -0,0 +1,82 @@
+From d798af685e9e1166400acbdab082c17b02dad85b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 18 May 2023 23:28:10 -0700
+Subject: [PATCH] Remove builddir and srcdir paths from test binaries
+
+Encoding buildtime paths is not needed since if these tests are to be
+run they will be run on target where builddir structure most certainly
+wont be available.
+
+Fixes
+WARNING: libpeas-1.36.0-r0 do_package_qa: QA Issue: File /usr/bin/peas-demo in package libpeas-demo contains reference to TMPDIR [buildpaths]
+
+Upstream-Status: Inappropriate [Cross-compile specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ peas-demo/meson.build | 2 +-
+ tests/libpeas-gtk/testing/meson.build | 4 ++--
+ tests/libpeas/testing/meson.build | 4 ++--
+ tests/testing-util/meson.build | 4 ++--
+ 4 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/peas-demo/meson.build b/peas-demo/meson.build
+index a3ec53b..855ebf2 100644
+--- a/peas-demo/meson.build
++++ b/peas-demo/meson.build
+@@ -9,7 +9,7 @@ peas_demo_c = [
+
+ peas_demo_c_args = [
+ '-DHAVE_CONFIG_H',
+- '-DPEAS_BUILDDIR="@0@"'.format(builddir),
++ '-DPEAS_BUILDDIR="/usr/src/debug/libpeas"',
+ '-DPEAS_PREFIX="@0@"'.format(prefix),
+ '-DPEAS_LIBDIR="@0@"'.format(libdir),
+ ]
+diff --git a/tests/libpeas-gtk/testing/meson.build b/tests/libpeas-gtk/testing/meson.build
+index 646f42d..fd9a692 100644
+--- a/tests/libpeas-gtk/testing/meson.build
++++ b/tests/libpeas-gtk/testing/meson.build
+@@ -19,8 +19,8 @@ libpeas_gtk_testing_deps = [
+
+ libpeas_gtk_testing_c_args = [
+ '-DHAVE_CONFIG_H',
+- '-DBUILDDIR="@0@"'.format(builddir),
+- '-DSRCDIR="@0@"'.format(srcdir),
++ '-DBUILDDIR="/usr/src/debug/libpeas"',
++ '-DSRCDIR="/usr/src/debug/libpeas"',
+ ]
+
+ libpeas_gtk_testing_lib = library(
+diff --git a/tests/libpeas/testing/meson.build b/tests/libpeas/testing/meson.build
+index 74ba7b1..084daa9 100644
+--- a/tests/libpeas/testing/meson.build
++++ b/tests/libpeas/testing/meson.build
+@@ -21,8 +21,8 @@ libpeas_testing_deps = [
+
+ libpeas_testing_c_args = [
+ '-DHAVE_CONFIG_H',
+- '-DBUILDDIR="@0@"'.format(builddir),
+- '-DSRCDIR="@0@"'.format(srcdir),
++ '-DBUILDDIR="/usr/src/debug/libpeas"',
++ '-DSRCDIR="/usr/src/debug/libpeas"',
+ ]
+
+ libpeas_testing_lib = library(
+diff --git a/tests/testing-util/meson.build b/tests/testing-util/meson.build
+index 1c40740..83ad059 100644
+--- a/tests/testing-util/meson.build
++++ b/tests/testing-util/meson.build
+@@ -17,8 +17,8 @@ libtesting_util_deps = [
+
+ libtesting_util_c_args = [
+ '-DHAVE_CONFIG_H',
+- '-DBUILDDIR="@0@"'.format(builddir),
+- '-DSRCDIR="@0@"'.format(srcdir),
++ '-DBUILDDIR="/usr/src/debug/libpeas"',
++ '-DSRCDIR="/usr/src/debug/libpeas"',
+ '-UG_DISABLE_ASSERT',
+ '-UG_DISABLE_CAST_CHECKS',
+ ]
+--
+2.40.1
+
diff --git a/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.36.0.bb b/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.36.0.bb
index 1282e93634..a32ea9b550 100644
--- a/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.36.0.bb
+++ b/meta-openembedded/meta-oe/recipes-gnome/libpeas/libpeas_1.36.0.bb
@@ -11,7 +11,10 @@ GTKDOC_MESON_OPTION = "gtk_doc"
inherit gnomebase gobject-introspection gtk-doc gtk-icon-cache features_check
ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+# FIXME: When upgrading to libpeas 2, g-i is no longer needed.
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+SRC_URI += "file://0001-Remove-builddir-and-srcdir-paths-from-test-binaries.patch"
SRC_URI[archive.sha256sum] = "297cb9c2cccd8e8617623d1a3e8415b4530b8e5a893e3527bbfd1edd13237b4c"
PACKAGECONFIG[python3] = "-Dpython3=true,-Dpython3=false,python3-pygobject"
diff --git a/meta-openembedded/meta-oe/recipes-gnome/vte9/vte9.inc b/meta-openembedded/meta-oe/recipes-gnome/vte9/vte9.inc
index 49b9740129..2a165391b6 100644
--- a/meta-openembedded/meta-oe/recipes-gnome/vte9/vte9.inc
+++ b/meta-openembedded/meta-oe/recipes-gnome/vte9/vte9.inc
@@ -1,7 +1,7 @@
SUMMARY = "Virtual terminal emulator GTK+ widget library"
BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
LICENSE = "LGPL-2.0-only"
-DEPENDS = " glib-2.0 gtk+ intltool-native gnome-common-native ncurses"
+DEPENDS = "glib-2.0-native glib-2.0 gtk+ intltool-native gnome-common-native ncurses"
RDEPENDS:libvte = "vte-termcap"
# help gnomebase get the SRC_URI correct