summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics/graphviz
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/graphviz')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.50.0.bb (renamed from meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.44.1.bb)37
1 files changed, 24 insertions, 13 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.44.1.bb b/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.50.0.bb
index ff9939ebd0..a9258e979a 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.44.1.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.50.0.bb
@@ -17,24 +17,21 @@ DEPENDS = " \
DEPENDS:append:class-target = " ${BPN}-native"
DEPENDS:append:class-nativesdk = " ${BPN}-native"
-inherit autotools-brokensep pkgconfig gettext
+inherit autotools-brokensep pkgconfig gettext qemu
-SRC_URI = "https://www2.graphviz.org/Packages/stable/portable_source/${BP}.tar.gz \
- file://0001-plugin-pango-Include-freetype-headers-explicitly.patch \
-"
+SRC_URI = "https://gitlab.com/api/v4/projects/4207231/packages/generic/${BPN}-releases/${PV}/${BP}.tar.xz \
+ "
# Use native mkdefs
SRC_URI:append:class-target = "\
- file://0001-Use-native-mkdefs.patch \
file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \
"
SRC_URI:append:class-nativesdk = "\
- file://0001-Use-native-mkdefs.patch \
file://graphviz-setup.sh \
"
-SRC_URI[sha256sum] = "8e1b34763254935243ccdb83c6ce108f531876d7a5dfd443f255e6418b8ea313"
+
+SRC_URI[sha256sum] = "6b16bf990df114195be669773a1dae975dbbffada45e1de2849ddeb5851bb9a8"
PACKAGECONFIG ??= "librsvg"
-PACKAGECONFIG:class-nativesdk ??= ""
PACKAGECONFIG[librsvg] = "--with-librsvg,--without-librsvg,librsvg"
EXTRA_OECONF:append = " PS2PDF=/bin/echo"
@@ -65,11 +62,6 @@ do_configure:prepend() {
./autogen.sh NOCONFIG || true
}
-do_install:append:class-native() {
- # install mkdefs for target build
- install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir}
-}
-
do_install:append:class-nativesdk() {
# graphviz-setup.sh must be executed at SDK installation
install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d
@@ -88,6 +80,23 @@ graphviz_sstate_postinst() {
}
SYSROOT_PREPROCESS_FUNCS:append:class-native = " graphviz_sstate_postinst"
+pkg_postinst:${PN} () {
+ if [ -n "$D" ]; then
+ if ${@bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'true', 'false', d)}; then
+ ${@qemu_run_binary(d, '$D', '${bindir}/dot')} -c
+ fi
+ else
+ dot -c
+ fi
+}
+
+pkg_postrm:${PN} () {
+ rm -f $D${libdir}/graphviz/config*
+ rmdir --ignore-fail-on-non-empty $D${libdir}/graphviz
+}
+
+PACKAGE_WRITE_DEPS += "qemu-native"
+
PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo"
FILES:${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/"
@@ -98,6 +107,8 @@ RDEPENDS:${PN}-perl += "perl"
RDEPENDS:${PN}-python += "python3"
RDEPENDS:${PN}-demo += "python3 perl"
+RRECOMMENDS:${PN} = "liberation-fonts"
+
INSANE_SKIP:${PN}-perl = "dev-so"
INSANE_SKIP:${PN}-python = "dev-so"