summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-multimedia')
-rw-r--r--meta-openembedded/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb1
-rw-r--r--meta-openembedded/meta-oe/recipes-multimedia/cdrkit/files/0001-genisoimage-Add-missing-extern-definition.patch29
-rw-r--r--meta-openembedded/meta-oe/recipes-multimedia/libopusenc/libopusenc_0.2.1.bb19
-rw-r--r--meta-openembedded/meta-oe/recipes-multimedia/live555/live555/config.linux-cross (renamed from meta-openembedded/meta-oe/recipes-multimedia/live555/files/config.linux-cross)2
-rw-r--r--meta-openembedded/meta-oe/recipes-multimedia/live555/live555_20190828.bb11
-rw-r--r--meta-openembedded/meta-oe/recipes-multimedia/live555/live555_20200721.bb (renamed from meta-openembedded/meta-oe/recipes-multimedia/live555/live555.inc)14
6 files changed, 60 insertions, 16 deletions
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb b/meta-openembedded/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
index 3b10e978ef..ebb95cf782 100644
--- a/meta-openembedded/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
+++ b/meta-openembedded/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
@@ -10,6 +10,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/c/${BPN}/${BPN}_${PV}.orig.tar.gz \
file://0001-genisoimage-Fix-fprintf-format-errors.patch \
file://0001-define-__THROW-to-avoid-build-issue-with-musl.patch \
file://0002-Do-not-use-rcmd-on-build-with-musl.patch \
+ file://0001-genisoimage-Add-missing-extern-definition.patch \
"
SRC_URI[md5sum] = "efe08e2f3ca478486037b053acd512e9"
SRC_URI[sha256sum] = "d1c030756ecc182defee9fe885638c1785d35a2c2a297b4604c0e0dcc78e47da"
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/cdrkit/files/0001-genisoimage-Add-missing-extern-definition.patch b/meta-openembedded/meta-oe/recipes-multimedia/cdrkit/files/0001-genisoimage-Add-missing-extern-definition.patch
new file mode 100644
index 0000000000..809d3afd76
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-multimedia/cdrkit/files/0001-genisoimage-Add-missing-extern-definition.patch
@@ -0,0 +1,29 @@
+From fd5251cc8b82ce7a5f907c5129969097d75609fe Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 13 Aug 2020 17:38:59 -0700
+Subject: [PATCH] genisoimage: Add missing extern definition
+
+Fixed build with gcc10
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ genisoimage/genisoimage.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/genisoimage/genisoimage.h b/genisoimage/genisoimage.h
+index bbedfb0..82c859b 100644
+--- a/genisoimage/genisoimage.h
++++ b/genisoimage/genisoimage.h
+@@ -376,7 +376,7 @@ extern int use_fileversion;
+ extern int split_SL_component;
+ extern int split_SL_field;
+ extern char *trans_tbl;
+-char *outfile;
++extern char *outfile;
+
+ #define JMAX 64 /* maximum Joliet file name length (spec) */
+ #define JLONGMAX 103 /* out of spec Joliet file name length */
+--
+2.28.0
+
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/libopusenc/libopusenc_0.2.1.bb b/meta-openembedded/meta-oe/recipes-multimedia/libopusenc/libopusenc_0.2.1.bb
new file mode 100644
index 0000000000..596c5fe86d
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-multimedia/libopusenc/libopusenc_0.2.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Opus Audio Codec"
+DESCRIPTION = "The libopusenc libraries provide a high-level API for encoding \
+ .opus files. libopusenc depends only on libopus."
+HOMEPAGE = "http://www.opus-codec.org/"
+SECTION = "libs/multimedia"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=174b92049c2c697eb73112801662a07c"
+
+DEPENDS = "libopus"
+
+UPSTREAM_CHECK_URI = "https://github.com/xiph/libopusenc/releases"
+
+SRC_URI = "https://ftp.osuosl.org/pub/xiph/releases/opus/libopusenc-${PV}.tar.gz"
+SRC_URI[md5sum] = "f038ea0f4168d184c76b42d293697c57"
+SRC_URI[sha256sum] = "8298db61a8d3d63e41c1a80705baa8ce9ff3f50452ea7ec1c19a564fe106cbb9"
+
+S = "${WORKDIR}/libopusenc-${PV}"
+
+inherit autotools pkgconfig
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/live555/files/config.linux-cross b/meta-openembedded/meta-oe/recipes-multimedia/live555/live555/config.linux-cross
index d1277da8d1..fe6a28604b 100644
--- a/meta-openembedded/meta-oe/recipes-multimedia/live555/files/config.linux-cross
+++ b/meta-openembedded/meta-oe/recipes-multimedia/live555/live555/config.linux-cross
@@ -12,6 +12,6 @@ CONSOLE_LINK_OPTS = $(LINK_OPTS)
LIBRARY_LINK = $(LD) -o
LIBRARY_LINK_OPTS = $(LINK_OPTS) -r -Bstatic
LIB_SUFFIX = a
-LIBS_FOR_CONSOLE_APPLICATION =
+LIBS_FOR_CONSOLE_APPLICATION = -lssl -lcrypto
LIBS_FOR_GUI_APPLICATION =
EXE =
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/live555/live555_20190828.bb b/meta-openembedded/meta-oe/recipes-multimedia/live555/live555_20190828.bb
deleted file mode 100644
index 1da61c0cf5..0000000000
--- a/meta-openembedded/meta-oe/recipes-multimedia/live555/live555_20190828.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require live555.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
- file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02 \
- "
-# SRC_URI[md5sum] = "a84ca3946d899f5592c7d31012ed2fe3"
-# SRC_URI[sha256sum] = "0bd0c26d980425d9a419d835193e292a08a968f175da1902da4b495f126d5abd"
-
-SRC_URI[md5sum] = "a593f915664793b3ba41299b17b8bedc"
-SRC_URI[sha256sum] = "a3dcd157865186cf883c3a80b4bb09637e91fff96b234b2c780a7f7dcc7a35dc"
-
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/live555/live555.inc b/meta-openembedded/meta-oe/recipes-multimedia/live555/live555_20200721.bb
index e08d11b0c2..df85cd4844 100644
--- a/meta-openembedded/meta-oe/recipes-multimedia/live555/live555.inc
+++ b/meta-openembedded/meta-oe/recipes-multimedia/live555/live555_20200721.bb
@@ -7,13 +7,23 @@ HOMEPAGE = "http://live.com/"
LICENSE = "LGPLv3"
SECTION = "devel"
+DEPENDS = "openssl"
+
URLV = "${@d.getVar('PV')[0:4]}.${@d.getVar('PV')[4:6]}.${@d.getVar('PV')[6:8]}"
SRC_URI = "https://download.videolan.org/pub/contrib/live555/live.${URLV}.tar.gz \
file://config.linux-cross"
+
# only latest live version stays on http://www.live555.com/liveMedia/public/, add mirror for older
MIRRORS += "http://www.live555.com/liveMedia/public/ http://download.videolan.org/contrib/live555/ \n"
+SRC_URI[sha256sum] = "89b2d99589de2ce9b4007ea6625dfce28317421604cf5131f4e1bf5bf7040b63"
+
S = "${WORKDIR}/live"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+ file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02 \
+ "
+
TARGET_CC_ARCH += "${LDFLAGS}"
do_configure() {
@@ -22,10 +32,6 @@ do_configure() {
./genMakefiles linux-cross
}
-do_compile() {
- oe_runmake
-}
-
do_install() {
install -d ${D}${includedir}/BasicUsageEnvironment
install -d ${D}${includedir}/groupsock