summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_0.364.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_0.364.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_0.364.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_0.364.bb b/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_0.364.bb
new file mode 100644
index 0000000000..6499db24f3
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/hwdata/hwdata_0.364.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Hardware identification and configuration data"
+HOMEPAGE = "https://github.com/vcrhonek/hwdata"
+SECTION = "System/Base"
+
+LICENSE = "GPL-2.0-or-later | XFree86-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57"
+
+SRCREV = "3ac83cecf56f299e7390e5afeab2808632719243"
+SRC_URI = "git://github.com/vcrhonek/${BPN}.git;branch=master;protocol=https"
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_configure() {
+ ${S}/configure --datadir=${datadir} --libdir=${libdir}
+}
+
+do_compile[noexec] = "1"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+FILES:${PN} = "${libdir}/* \
+ ${datadir}/* "