summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb b/meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
index fb37de3c30..0bb06c1d1f 100644
--- a/meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
@@ -27,6 +27,7 @@ S = "${WORKDIR}/git"
inherit cmake pkgconfig ptest
LIBATOMIC:mips:toolchain-clang = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}"
+LIBATOMIC:riscv32:toolchain-clang = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}"
PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
PACKAGECONFIG[with-tests] = "-DWITH_WERROR=OFF -DBUILD_TESTS=ON ${LIBATOMIC},,"
@@ -43,3 +44,7 @@ ALLOW_EMPTY:${PN} = "1"
RDEPENDS:${PN}-dev = ""
BBCLASSEXTEND = "native nativesdk"
+
+#it needs to work with CXXFLAGS += " -mlong-double-64" but ppc64 only supports 128bit long double
+COMPATIBLE_HOST:powerpc64le = "null"
+COMPATIBLE_HOST:powerpc = "null"