summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/pcp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/pcp')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pcp/pcp-native_6.0.5.bb (renamed from meta-openembedded/meta-oe/recipes-support/pcp/pcp-native_5.3.6.bb)5
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pcp/pcp.inc28
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-Remove-unsuitble-part-for-cross-compile.patch14
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-configure-Limit-the-header-search-to-sysroot.patch49
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-htop-Change-dependency-order-of-header-and-sourcefil.patch36
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pcp/pcp_6.0.5.bb (renamed from meta-openembedded/meta-oe/recipes-support/pcp/pcp_5.3.6.bb)32
6 files changed, 81 insertions, 83 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/pcp/pcp-native_5.3.6.bb b/meta-openembedded/meta-oe/recipes-support/pcp/pcp-native_6.0.5.bb
index 5f3c9b6f00..2f37b099b4 100644
--- a/meta-openembedded/meta-oe/recipes-support/pcp/pcp-native_5.3.6.bb
+++ b/meta-openembedded/meta-oe/recipes-support/pcp/pcp-native_6.0.5.bb
@@ -46,8 +46,3 @@ do_install () {
PCP_MAN_DIR=${D}/${mandir} \
PCP_DOC_DIR=${D}/${docdir}
}
-#| chkacc1.c:8:10: fatal error: localconfig.h: No such file or directory
-#| 8 | #include "localconfig.h"
-#| | ^~~~~~~~~~~~~~~
-PARALLEL_MAKE = ""
-
diff --git a/meta-openembedded/meta-oe/recipes-support/pcp/pcp.inc b/meta-openembedded/meta-oe/recipes-support/pcp/pcp.inc
index 708ebfe7ab..4cafa7234b 100644
--- a/meta-openembedded/meta-oe/recipes-support/pcp/pcp.inc
+++ b/meta-openembedded/meta-oe/recipes-support/pcp/pcp.inc
@@ -9,24 +9,32 @@ COMPATIBLE_HOST:libc-musl = "null"
SRC_URI = "https://performancecopilot.jfrog.io/artifactory/pcp-source-release/${BP}.src.tar.gz \
file://0001-configure-Limit-the-header-search-to-sysroot.patch \
+ file://0001-htop-Change-dependency-order-of-header-and-sourcefil.patch \
file://config.linux \
"
-SRC_URI[sha256sum] = "6ef33b7aa14c09860ba7cd8873e76d38ccd24eab0c94a50e235f813e77fe3610"
+SRC_URI[sha256sum] = "dacf92ba195f1f2ea8f40bf0c455d2cd2456273a1e30dcc3ee5b5bfd099a99ee"
inherit setuptools3-base pkgconfig autotools-brokensep
# Specify any options you want to pass to the configure script using EXTRA_OECONF:
CACHED_CONFIGUREVARS = "PACKAGE_DISTRIBUTION=arch"
-EXTRA_OECONF:append = " --with-dstat-symlink=yes --with-infiniband=no \
- --with-pmdapodman=no --with-python=no --with-python3=yes --with-perl=no \
- --with-pmdabcc=no --with-pmdajson=no --with-perfevent=no \
- --with-pmdabcc=yes \
- --with-rundir=${localstatedir}/run \
- --with-sysconfigdir=${sysconfdir} \
- --with-logdir=${localstatedir}/log \
- --with-docdir=${docdir} \
- "
+EXTRA_OECONF:append = "\
+ --with-dstat-symlink=yes \
+ --with-infiniband=no \
+ --with-python=no \
+ --with-perl=no \
+ --with-python3=yes \
+ --with-pmdajson=no \
+ --with-perfevent=no \
+ --with-pmdabcc=yes \
+ --with-rundir=${localstatedir}/run \
+ --with-sysconfigdir=${sysconfdir} \
+ --with-logdir=${localstatedir}/log \
+ --with-docdir=${docdir} \
+ "
PACKAGECONFIG[qt5] = "--with-qt=yes --with-qt3d=yes,--with-qt=no --with-qt3d=no,qtbase qt3d"
PACKAGECONFIG ?= ""
+
+PARALLEL_MAKE = ""
diff --git a/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-Remove-unsuitble-part-for-cross-compile.patch b/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-Remove-unsuitble-part-for-cross-compile.patch
index 292499850e..abf4aee61d 100644
--- a/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-Remove-unsuitble-part-for-cross-compile.patch
+++ b/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-Remove-unsuitble-part-for-cross-compile.patch
@@ -11,11 +11,9 @@ Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
src/libpcp/src/GNUmakefile | 1 -
2 files changed, 7 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index 5b25382..5d24714 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -623,12 +623,6 @@ fi
+@@ -607,12 +607,6 @@ fi
which=$WHICH
AC_SUBST(which)
@@ -28,18 +26,14 @@ index 5b25382..5d24714 100644
ar=$AR
AC_SUBST(ar)
-diff --git a/src/libpcp/src/GNUmakefile b/src/libpcp/src/GNUmakefile
-index 3c4ccd6..d1eba19 100644
--- a/src/libpcp/src/GNUmakefile
+++ b/src/libpcp/src/GNUmakefile
-@@ -176,7 +176,6 @@ exports: exports.in mk.exports
- # cases
+@@ -179,8 +179,6 @@ exports: exports.in mk.exports
+ # consistent in all placess.
#
check.done: $(OBJECTS)
- ./check-statics
+- ./check-errorcodes
touch check.done
ifneq ($(LIBTARGET),)
---
-2.25.1
-
diff --git a/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-configure-Limit-the-header-search-to-sysroot.patch b/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-configure-Limit-the-header-search-to-sysroot.patch
index 591f94f374..b03c48e581 100644
--- a/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-configure-Limit-the-header-search-to-sysroot.patch
+++ b/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-configure-Limit-the-header-search-to-sysroot.patch
@@ -14,11 +14,9 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
configure.ac | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index 5d24714..4e2d8ec 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -913,7 +913,7 @@ AC_DEFUN([PCP_CHECK_PYTHON_HEADER],
+@@ -907,7 +907,7 @@ AC_DEFUN([PCP_CHECK_PYTHON_HEADER],
[ PY_MAJOR="$1"
PY_MINOR="$2"
PY_VERSION="python$PY_MAJOR.$PY_MINOR"
@@ -27,7 +25,7 @@ index 5d24714..4e2d8ec 100644
saved_CFLAGS="$CFLAGS"
saved_CPPFLAGS="$CPPFLAGS"
CFLAGS="$CFLAGS $PY_INCLUDE_DIRS"
-@@ -1524,7 +1524,7 @@ AC_SUBST(qmake)
+@@ -1603,7 +1603,7 @@ AC_SUBST(qmake)
enable_qt3d=false
AS_IF([test "x$do_qt3d" != "xno"], [
@@ -36,45 +34,7 @@ index 5d24714..4e2d8ec 100644
then
enable_qt3d=$enable_qt
elif test x"$do_qt3d" = x"yes"
-@@ -3810,13 +3810,13 @@ then
-
- saved_CFLAGS="$CFLAGS"
- saved_CPPFLAGS="$CPPFLAGS"
-- NSS_INC_DIRS="-I/usr/include/nss -I/usr/include/nss3"
-- NSPR_INC_DIRS="-I/usr/include/nspr -I/usr/include/nspr4"
-+ NSS_INC_DIRS="-I${STAGING_INCDIR}/nss -I${STAGING_INCDIR}/nss3"
-+ NSPR_INC_DIRS="-I${STAGING_INCDIR}/nspr -I${STAGING_INCDIR}/nspr4"
- CFLAGS="$CFLAGS $NSS_INC_DIRS $NSPR_INC_DIRS"
- CPPFLAGS="$CPPFLAGS $NSS_INC_DIRS $NSPR_INC_DIRS"
-
-- AC_CHECK_HEADERS([nss/nss.h], [NSSCFLAGS=-I/usr/include/nss], [
-- AC_CHECK_HEADERS([nss3/nss.h], [NSSCFLAGS=-I/usr/include/nss3], [
-+ AC_CHECK_HEADERS([nss/nss.h], [NSSCFLAGS=-I${STAGING_INCDIR}/nss], [
-+ AC_CHECK_HEADERS([nss3/nss.h], [NSSCFLAGS=-I${STAGING_INCDIR}/nss3], [
- enable_secure=false
- if test "$do_secure" = "yes"
- then
-@@ -3826,8 +3826,8 @@ then
- ])
- AC_SUBST(NSSCFLAGS)
-
-- AC_CHECK_HEADERS([nspr/nspr.h], [NSPRCFLAGS=-I/usr/include/nspr], [
-- AC_CHECK_HEADERS([nspr4/nspr.h], [NSPRCFLAGS=-I/usr/include/nspr4], [
-+ AC_CHECK_HEADERS([nspr/nspr.h], [NSPRCFLAGS=-I${STAGING_INCDIR}/nspr], [
-+ AC_CHECK_HEADERS([nspr4/nspr.h], [NSPRCFLAGS=-I${STAGING_INCDIR}/nspr4], [
- enable_secure=false
- if test "$do_secure" = "yes"
- then
-@@ -3837,7 +3837,7 @@ then
- ])
- AC_SUBST(NSPRCFLAGS)
-
-- AC_CHECK_HEADERS([sasl/sasl.h], [SASLCFLAGS=-I/usr/include/sasl], [
-+ AC_CHECK_HEADERS([sasl/sasl.h], [SASLCFLAGS=-I${STAGING_INCDIR}/sasl], [
- enable_secure=false
- if test "$do_secure" = "yes"
- then
-@@ -3938,7 +3938,7 @@ AC_SUBST(enable_decompression)
+@@ -3699,7 +3699,7 @@ AC_SUBST(enable_decompression)
AC_SUBST(enable_lzma)
dnl check for array sessions
@@ -83,6 +43,3 @@ index 5d24714..4e2d8ec 100644
then
pcp_mpi_dirs=libpcp_mpi\ libpcp_mpiread
else
---
-2.35.1
-
diff --git a/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-htop-Change-dependency-order-of-header-and-sourcefil.patch b/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-htop-Change-dependency-order-of-header-and-sourcefil.patch
new file mode 100644
index 0000000000..009dfe2d04
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/pcp/pcp/0001-htop-Change-dependency-order-of-header-and-sourcefil.patch
@@ -0,0 +1,36 @@
+From c123980d6bf1bc2bf93ee0dd0d7f8fee3d4ddc96 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 5 Jul 2023 08:45:14 -0700
+Subject: [PATCH] htop: Change dependency order of header and sourcefiles
+
+Fixes build race
+| pcp/Platform.h:29:10: fatal error: DiskIOMeter.h: No such file or directory
+| 29 | #include "DiskIOMeter.h"
+| | ^~~~~~~~~~~~~~~
+| compilation terminated.
+| make[3]: *** [<builtin>: pcp-htop.o] Error 1
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/pcp/htop/GNUmakefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/pcp/htop/GNUmakefile b/src/pcp/htop/GNUmakefile
+index 6b7c0c5..5153c63 100644
+--- a/src/pcp/htop/GNUmakefile
++++ b/src/pcp/htop/GNUmakefile
+@@ -186,8 +186,8 @@ CFGMETERS = $(patsubst %,pcp/meters/%,$(METERS))
+ CFGCOLUMNS = $(patsubst %,pcp/columns/%,$(COLUMNS))
+
+ CFGXFILES = $(CFGMETERS) $(CFGCOLUMNS)
+-TOPXFILES = $(TOPCFILES) $(TOPHFILES) $(DOCFILES)
+-SUBXFILES = $(SUBCFILES) $(SUBHFILES)
++TOPXFILES = $(TOPHFILES) $(TOPCFILES) $(DOCFILES)
++SUBXFILES = $(SUBHFILES) $(SUBCFILES)
+ CFILES = $(TOPCFILES) $(SUBCFILES)
+ HFILES = $(TOPHFILES) $(SUBHFILES)
+ LDIRT = $(TOPXFILES) $(SUBXFILES) $(CFGXFILES) \
+--
+2.41.0
+
diff --git a/meta-openembedded/meta-oe/recipes-support/pcp/pcp_5.3.6.bb b/meta-openembedded/meta-oe/recipes-support/pcp/pcp_6.0.5.bb
index 0543d77a78..b337df6ea4 100644
--- a/meta-openembedded/meta-oe/recipes-support/pcp/pcp_5.3.6.bb
+++ b/meta-openembedded/meta-oe/recipes-support/pcp/pcp_6.0.5.bb
@@ -18,17 +18,26 @@ SRC_URI += "file://0001-Remove-unsuitble-part-for-cross-compile.patch \
export PCP_DIR="${RECIPE_SYSROOT_NATIVE}"
#export PCP_RUN_DIR="${RECIPE_SYSROOT_NATIVE}"
EXTRA_OEMAKE = "CC="${CC}" LD="${LD}""
-inherit useradd systemd features_check
+inherit useradd systemd features_check python3targetconfig
# Needs libx11
REQUIRED_DISTRO_FEATURES = "x11"
SYSTEMD_AUTO_ENABLE:${PN} = "enable"
-SYSTEMD_SERVICE:${PN} = "pmcd.service pmcd.service pmie_check.service pmie_farm_check.service \
- pmlogger_daily.service pmlogger_farm_check.service pmfind.service \
- pmie_daily.service pmlogger.service pmlogger_daily_report.service \
- pmproxy.service pmie.service pmie_farm.service pmlogger_check.service \
- pmlogger_farm.service"
+SYSTEMD_SERVICE:${PN} = "\
+ pmie_farm_check.service \
+ pmie_farm.service \
+ pmfind.service \
+ pmlogger_farm_check.service \
+ pmcd.service \
+ pmie.service \
+ pmlogger_daily.service \
+ pmlogger.service \
+ pmlogger_farm.service \
+ pmie_check.service \
+ pmproxy.service \
+ pmlogger_check.service \
+ pmie_daily.service"
USERADD_PACKAGES = "${PN}"
USERADD_PARAM:${PN} = "--system --home ${localstatedir}/lib/pcp --no-create-home \
@@ -88,7 +97,7 @@ do_install () {
PACKAGES += " ${PN}-export-zabbix-agent ${PN}-testsuite \
libpcp-gui2 libpcp-gui2-dev \
- libpcp-import1 \
+ libpcp-import1 libpcp-archive1 \
libpcp-mmv1 libpcp-mmv1-dev \
libpcp-pmda3 libpcp-pmda3-dev \
libpcp-trace2 libpcp-trace2-dev \
@@ -97,6 +106,8 @@ PACKAGES += " ${PN}-export-zabbix-agent ${PN}-testsuite \
"
FILES:libpcp-gui2 = "${libdir}/libpcp_gui.so.2 \
"
+FILES:libpcp-archive1 = "${libdir}/libpcp_archive.so.1 \
+"
FILES:libpcp-gui2-dev = " \
${libdir}/libpcp_gui.so \
${libdir}/libpcp_gui.a \
@@ -166,6 +177,7 @@ FILES:${PN} = " \
${datadir}/zsh \
${systemd_system_unitdir}/ \
${libdir}/pcp/ \
+ ${libdir}/sysusers.d/pcp.conf \
${datadir}/pcp \
${libdir}/*.sh \
${datadir}/man \
@@ -184,7 +196,7 @@ FILES:${PN}-export-zabbix-agent += " \
${mandir}/man3/zbxpcp.3.gz \
${libdir}/zabbix \
"
-FILES:${PN}-testsuite = "${localstatedir}/lib/pcp/testsuite/"
+FILES:${PN}-testsuite = "${localstatedir}/lib/pcp/testsuite/ ${libdir}/sysusers.d/pcp-testsuite.conf"
FILES:python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}"
FILES:${PN}-dev += " \
${includedir}/pcp \
@@ -222,7 +234,3 @@ FILES:${PN}-dev += " \
${datadir}/man/man3/pms* \
${datadir}/man/man3/pmt* \
"
-#| chkacc1.c:8:10: fatal error: localconfig.h: No such file or directory
-#| 8 | #include "localconfig.h"
-#| | ^~~~~~~~~~~~~~~
-PARALLEL_MAKE = ""