summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/pidgin
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/pidgin')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pidgin/gmime/iconv-detect.h5
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pidgin/gmime/nodolt.patch10
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pidgin/gmime_3.2.4.bb23
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pidgin/pidgin-sipe/0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch50
-rw-r--r--meta-openembedded/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb1
5 files changed, 51 insertions, 38 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/pidgin/gmime/iconv-detect.h b/meta-openembedded/meta-oe/recipes-support/pidgin/gmime/iconv-detect.h
deleted file mode 100644
index 714cb5aa9d..0000000000
--- a/meta-openembedded/meta-oe/recipes-support/pidgin/gmime/iconv-detect.h
+++ /dev/null
@@ -1,5 +0,0 @@
-/* This is an auto-generated header, DO NOT EDIT! */
-
-#define ICONV_ISO_INT_FORMAT "iso-%u-%u"
-#define ICONV_ISO_STR_FORMAT "iso-%u-%s"
-#define ICONV_10646 "iso-10646"
diff --git a/meta-openembedded/meta-oe/recipes-support/pidgin/gmime/nodolt.patch b/meta-openembedded/meta-oe/recipes-support/pidgin/gmime/nodolt.patch
deleted file mode 100644
index 1f9bdd3041..0000000000
--- a/meta-openembedded/meta-oe/recipes-support/pidgin/gmime/nodolt.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -150,7 +150,6 @@ AC_EXEEXT
- AC_PROG_LIBTOOL
- dnl when using libtool 2.x create libtool early, because it's used in configure
- m4_ifdef([LT_OUTPUT], [LT_OUTPUT])
--DOLT
-
- dnl Checks for header files.
- AC_CHECK_HEADERS(sys/mman.h)
diff --git a/meta-openembedded/meta-oe/recipes-support/pidgin/gmime_3.2.4.bb b/meta-openembedded/meta-oe/recipes-support/pidgin/gmime_3.2.4.bb
deleted file mode 100644
index dcdaed5a2c..0000000000
--- a/meta-openembedded/meta-oe/recipes-support/pidgin/gmime_3.2.4.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-LICENSE = "LGPL-2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-DESCRIPTION = "Runtime libraries for parsing and creating MIME mail"
-SECTION = "libs"
-DEPENDS = "glib-2.0 zlib"
-
-inherit gnomebase autotools gobject-introspection
-
-SRC_URI += "file://iconv-detect.h \
- file://nodolt.patch"
-
-SRC_URI[archive.md5sum] = "b6b4e9fdc8f3336551d23872c83b539a"
-SRC_URI[archive.sha256sum] = "249ea7c0e080b067aa9669162c36b181b402f6cf6cebc4999d838c6f1e81d024"
-
-EXTRA_OECONF_remove = "--disable-schemas-install"
-
-export ac_cv_have_iconv_detect_h="yes"
-do_configure_append = "cp ${WORKDIR}/iconv-detect.h ${S}"
-
-# we do not need GNOME 1 gnome-config support
-do_install_append () {
- rm -f ${D}${libdir}/gmimeConf.sh
-}
diff --git a/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin-sipe/0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch b/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin-sipe/0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch
new file mode 100644
index 0000000000..87a6435f7e
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin-sipe/0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch
@@ -0,0 +1,50 @@
+From 1110d3036e73d0571f70f6758f3179e5048c0b5d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 16 Nov 2019 11:07:42 -0800
+Subject: [PATCH] Align structs casts with time_t elements to 8byte boundary
+
+This helps with 64bit time_t conversion, especially where these
+structures are typcasted to another struct types which have time_t
+element, that now increases the natural alignment boundary of structures
+to 8-bytes.
+
+Fixes
+../../../pidgin-sipe-1.25.0/src/core/sipe-user.c:124:43: error: cast from 'struct sipe_core_public *' to 'struct sipe_core_private *' increases required alignment from 4 to 8 [-Werror,-Wcast-align]
+ struct sipe_core_private *sipe_private = SIPE_CORE_PRIVATE;
+ ^~~~~~~~~~~~~~~~~
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/api/sipe-core.h | 2 +-
+ src/core/sipe-http-transport.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/api/sipe-core.h b/src/api/sipe-core.h
+index cde0a9c..bd818bb 100644
+--- a/src/api/sipe-core.h
++++ b/src/api/sipe-core.h
+@@ -148,7 +148,7 @@ struct sipe_core_public {
+
+ /* server information */
+ /* currently nothing */
+-};
++} __attribute__((aligned(8)));
+
+ /**
+ * Initialize & destroy functions for the SIPE core
+diff --git a/src/core/sipe-http-transport.h b/src/core/sipe-http-transport.h
+index d82cd1b..08eb150 100644
+--- a/src/core/sipe-http-transport.h
++++ b/src/core/sipe-http-transport.h
+@@ -46,7 +46,7 @@ struct sipe_http_connection_public {
+ gchar *host;
+ guint32 port;
+ gboolean connected;
+-};
++} __attribute__((aligned(8)));
+
+ /**
+ * Check if we're shutting down the HTTP stack
+--
+2.24.0
+
diff --git a/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb b/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb
index 7dc63164e3..99fcf3c6d0 100644
--- a/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb
+++ b/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin-sipe_1.25.0.bb
@@ -9,6 +9,7 @@ inherit autotools gettext pkgconfig
SRC_URI = "${SOURCEFORGE_MIRROR}/sipe/pidgin-sipe-${PV}.tar.xz \
file://0001-sipe-consider-64bit-time_t-when-printing.patch \
+ file://0001-Align-structs-casts-with-time_t-elements-to-8byte-bo.patch \
"
SRC_URI[md5sum] = "0e742f021dc8c3f17435aea05c3e0314"