summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/spdlog/spdlog_1.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/spdlog/spdlog_1.10.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/spdlog/spdlog_1.10.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/spdlog/spdlog_1.10.0.bb b/meta-openembedded/meta-oe/recipes-support/spdlog/spdlog_1.10.0.bb
new file mode 100644
index 0000000000..a7d9263513
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/spdlog/spdlog_1.10.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Very fast, header only, C++ logging library."
+HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRCREV = "76fb40d95455f249bd70824ecfcae7a8f0930fa3"
+SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x"
+
+DEPENDS += "fmt"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+# no need to build example & tests & benchmarks on pure yocto
+EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on"
+
+inherit cmake