summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-apispec_6.4.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-apispec_6.3.1.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-engineio_4.8.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-engineio_4.8.1.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-eth-hash_0.6.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-eth-hash_0.5.2.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-google-api-python-client_2.113.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-google-api-python-client_2.112.0.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-google-auth_2.26.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-google-auth_2.26.1.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-marshmallow_3.20.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-marshmallow_3.20.1.bb)10
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_4.25.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_4.25.1.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_5.11.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_5.10.0.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-web3_6.14.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-web3_6.13.0.bb)2
9 files changed, 12 insertions, 16 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-apispec_6.3.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-apispec_6.4.0.bb
index 6b9f704a68..a48e1cfaee 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-apispec_6.3.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-apispec_6.4.0.bb
@@ -1,10 +1,10 @@
SUMMARY = "A pluggable API specification generator. Currently supports the OpenAPI Specification (f.k.a. the Swagger specification)."
HOMEPAGE = "https://github.com/marshmallow-code/apispec"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=824d596e050c0d5e3361efb438425945"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3d9c303644a2e62578f0347748a80358"
inherit pypi setuptools3
-SRC_URI[sha256sum] = "b38e4479916d43f2b1e88ce15fc2fae93adf2e8d55cb59ec74ac66a827941483"
+SRC_URI[sha256sum] = "42b8a6833cf154c9dbd22d006b56bf9c49c972d32d24fe716fd734e0f6b739b8"
RDEPENDS:${PN} += "python3-packaging"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-engineio_4.8.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-engineio_4.8.2.bb
index f88a3acf1e..9dad138ea2 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-engineio_4.8.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-engineio_4.8.2.bb
@@ -17,4 +17,4 @@ RDEPENDS:${PN} += " \
python3-asyncio \
"
-SRC_URI[sha256sum] = "fadc39c66348f96476d8dc2d7aaee7ea0a39d96e333217f5321300677b980121"
+SRC_URI[sha256sum] = "f8609e3afdda318fdc336b4ba2de8dd397bb8f9b8a1b43e56c27330e32c2e34c"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-eth-hash_0.5.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-eth-hash_0.6.0.bb
index 683d84761c..77e6565272 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-eth-hash_0.5.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-eth-hash_0.6.0.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3d7bdfe69b1ffbde073ca6e96f5c53f7"
-SRC_URI[sha256sum] = "1b5f10eca7765cc385e1430eefc5ced6e2e463bb18d1365510e2e539c1a6fe4e"
+SRC_URI[sha256sum] = "ae72889e60db6acbb3872c288cfa02ed157f4c27630fcd7f9c8442302c31e478"
inherit pypi setuptools3
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-google-api-python-client_2.112.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-google-api-python-client_2.113.0.bb
index b1614b854f..4e6bb7daf6 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-google-api-python-client_2.112.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-google-api-python-client_2.113.0.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/googleapis/google-api-python-client"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-SRC_URI[sha256sum] = "c3bcb5fd70d57f4c94b30c0dbeade53c216febfbf1d771eeb1a2fa74bd0d6756"
+SRC_URI[sha256sum] = "bcffbc8ffbad631f699cf85aa91993f3dc03060b234ca9e6e2f9135028bd9b52"
inherit pypi setuptools3
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-google-auth_2.26.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-google-auth_2.26.2.bb
index 1a4913b718..9bd0926ca6 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-google-auth_2.26.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-google-auth_2.26.2.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
inherit pypi setuptools3
-SRC_URI[sha256sum] = "54385acca5c0fbdda510cd8585ba6f3fcb06eeecf8a6ecca39d3ee148b092590"
+SRC_URI[sha256sum] = "97327dbbf58cccb58fc5a1712bba403ae76668e64814eb30f7316f7e27126b81"
RDEPENDS:${PN} += "\
${PYTHON_PN}-asyncio \
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-marshmallow_3.20.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-marshmallow_3.20.2.bb
index f0ca630ccd..c08aec5bec 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-marshmallow_3.20.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-marshmallow_3.20.2.bb
@@ -3,16 +3,12 @@ DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converti
HOMEPAGE = "https://github.com/marshmallow-code/marshmallow"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "\
- file://LICENSE;md5=5bccd400dedfa74364481e56aacc0b4a \
+ file://LICENSE;md5=653847350fed2e0e7b02791a35b98d59 \
file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb"
-SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev"
+SRC_URI[sha256sum] = "4c1daff273513dc5eb24b219a8035559dc573c8f322558ef85f5438ddd1236dd"
-SRCREV = "dda9a8014dfe1bcb35e21307cfd5a8e19615a284"
-
-S = "${WORKDIR}/git"
-
-inherit setuptools3
+inherit setuptools3 pypi
PIP_INSTALL_PACKAGE = "marshmallow"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_4.25.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_4.25.2.bb
index 3c770e41d3..5333d306bd 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_4.25.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_4.25.2.bb
@@ -6,7 +6,7 @@ LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=53dbfa56f61b90215a9f8f0d527c043d"
inherit pypi setuptools3
-SRC_URI[sha256sum] = "57d65074b4f5baa4ab5da1605c02be90ac20c8b40fb137d6a8df9f416b0d0ce2"
+SRC_URI[sha256sum] = "fe599e175cb347efc8ee524bcd4b902d11f7262c0e569ececcb89995c15f0a5e"
# http://errors.yoctoproject.org/Errors/Details/184715/
# Can't find required file: ../src/google/protobuf/descriptor.proto
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_5.10.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_5.11.0.bb
index 68168bb635..72471e956a 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_5.10.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_5.11.0.bb
@@ -9,7 +9,7 @@ inherit pypi python_setuptools_build_meta
PYPI_PACKAGE = "python-socketio"
-SRC_URI[sha256sum] = "01c616946fa9f67ed5cc3d1568e1c4940acfc64aeeb9ff621a53e80cabeb748a"
+SRC_URI[sha256sum] = "b03186e04b942088781f6286c13604a853e5e35ed59158c51ff7af22fa032e6f"
PACKAGECONFIG ?= "asyncio_client client"
PACKAGECONFIG[asyncio_client] = ",,,${PYTHON_PN}-aiohttp ${PYTHON_PN}-websockets"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-web3_6.13.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-web3_6.14.0.bb
index 0f0682fca4..177c6fc030 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-web3_6.13.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-web3_6.14.0.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=373fede350846fdffd23648fba504635"
-SRC_URI[sha256sum] = "769ab3cfffea69c6b495c63a1aecdb522651c0304260fc25467a886d0be622e2"
+SRC_URI[sha256sum] = "a3726289da9eff2ce30f9b1b49ec59e9245216f7aecbfa2007f73dbe94999717"
inherit pypi setuptools3