summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb')
-rw-r--r--meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb19
1 files changed, 9 insertions, 10 deletions
diff --git a/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb b/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
index 75a1efecfb..4b6cd331d4 100644
--- a/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
+++ b/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
@@ -1,25 +1,24 @@
SUMMARY = "Network Block Device Proxy"
HOMEPAGE = "https://github.com/openbmc/jsnbd"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-inherit autotools pkgconfig
-
DEPENDS += "json-c"
DEPENDS += "udev"
+SRCREV = "3ebe3dadd3f550d20080c8bb14dee113e322eb61"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
-RDEPENDS:${PN} += "nbd-client"
+SRC_URI = "git://github.com/openbmc/jsnbd;branch=master;protocol=https"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/jsnbd;branch=master;protocol=https"
-SRCREV = "3ebe3dadd3f550d20080c8bb14dee113e322eb61"
-
-NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"
+inherit autotools pkgconfig
do_install:append() {
install -d ${D}${sysconfdir}/nbd-proxy/
install -m 0644 ${NBD_PROXY_CONFIG_JSON} ${D}${sysconfdir}/nbd-proxy/config.json
}
+
+RDEPENDS:${PN} += "nbd-client"
+
+NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"