summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core/os-release/os-release.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-core/os-release/os-release.bbappend')
-rw-r--r--meta-phosphor/recipes-core/os-release/os-release.bbappend7
1 files changed, 0 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-core/os-release/os-release.bbappend b/meta-phosphor/recipes-core/os-release/os-release.bbappend
index 50c3787e4a..e587825723 100644
--- a/meta-phosphor/recipes-core/os-release/os-release.bbappend
+++ b/meta-phosphor/recipes-core/os-release/os-release.bbappend
@@ -6,7 +6,6 @@
# what that means!
OS_RELEASE_ROOTPATH ?= "${COREBASE}"
-
def run_git(d, cmd):
try:
oeroot = d.getVar('OS_RELEASE_ROOTPATH', True)
@@ -16,7 +15,6 @@ def run_git(d, cmd):
except Exception as e:
bb.warn("Unexpected exception from 'git' call: %s" % e)
pass
-
# DISTRO_VERSION can be overridden by a bbappend or config, so it must be a
# weak override. But, when a variable is weakly overridden the definition
# and not the contents are used in the task-hash (for sstate reuse). We need
@@ -26,15 +24,10 @@ def run_git(d, cmd):
PHOSPHOR_OS_RELEASE_DISTRO_VERSION := "${@run_git(d, 'describe --dirty')}"
DISTRO_VERSION ??= "${PHOSPHOR_OS_RELEASE_DISTRO_VERSION}"
EXTENDED_VERSION ??= "${PHOSPHOR_OS_RELEASE_DISTRO_VERSION}"
-
VERSION = "${@'-'.join(d.getVar('VERSION_ID').split('-')[0:2])}"
-
OPENBMC_TARGET_MACHINE = "${MACHINE}"
-
OS_RELEASE_FIELDS:append = " BUILD_ID OPENBMC_TARGET_MACHINE EXTENDED_VERSION"
-
# Ensure the git commands run every time bitbake is invoked.
BB_DONT_CACHE = "1"
-
# Make os-release available to other recipes.
SYSROOT_DIRS:append = " ${sysconfdir}"